Bug 5829 - localhost not valid for cgi-bin
Summary: localhost not valid for cgi-bin
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-11 13:47 UTC by mjhns
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-02 15:48:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mjhns 1999-10-11 13:47:44 UTC
Netscape is only where the presenting problem occurs.

in 5.0, when I typed http://localhost/cgi-bin/guestbook.pl
into the URL slot, my cgi form came up fine.

in 6.0, when I type precisely the same string, netscape
can't find the URL.

On the one hand, I feel dumb not knowing the right formula
to do this now. On the other hand, something that worked
for me is now 'broken'.

Thanks for your help,

Mike H

Comment 1 Bill Nottingham 1999-10-11 14:32:59 UTC
What does your apache configuration look like?

------- Additional Comments From   10/15/99 12:32 -------
the /etc/httpd/conf/*.conf files are vanilla redhat. I don't know if
there's any way to attach files to this 'bug' report. I did email the
.conf files to the assigned address.

The ScriptAlias line is:
ScriptAlias /cgi-bin/ /home/httpd/cgi-bin/

The problem is that localhost is not recognised as a valid server.

I've just changed httpd.conf, so LogLevel is debug, typed
http://localhost/cgi-bin/guestbook.pl.

Found that it was expanded to:
http://www.localhost.com/cgi-bin/guestbook.pl
which, of course, was not found. Got message:

The requested URL /cgi/guestbook.pl was not found on this server
Apache/1.3.9 Server at www.localhost.com port 80

Hope this provides some extra clues.

Mike H

Comment 2 Bill Nottingham 1999-10-15 16:34:59 UTC
What does your /etc/hosts look like?

Comment 3 mjhns 1999-10-17 00:08:59 UTC
/etc/hosts is vanilla:

127.0.0.1    localhost    localhost.localdomain

Comment 4 Bill Nottingham 1999-10-18 21:14:59 UTC
what does /etc/nsswitch.conf & /etc/resolv.conf say?

Comment 5 mjhns 1999-10-20 14:35:59 UTC
/etc/resolve.conf:
<<<
search cpinternet.com uslink.net
nameserver 204.220.140.1
nameserver 199.199.168.3
>>>

Summary of /etc/nsswitch.conf:
<<<
passwd, shadow, group: files nisplus nis
hosts                : files nisplus nis dns
services, networks, protocols, rpc, ethers, netmasks, bootparams
                     : nisplus [NOTFOUND=return] files
netgroup, publickey  : nisplus
automount, aliases   : files nisplus
>>>

At a guess, might I need a localhost entry in my resolv.conf, and/or a
tweek to the hosts entry in nsswitch.conf? Or something completely
different.

Thanks,

Mike H

Comment 6 Bill Nottingham 1999-10-20 16:25:59 UTC
Hmm... it all looks sane. With similar setup, it works fine here.

Comment 7 mjhns 1999-10-29 19:38:59 UTC
Hi, I'm back.

I've cast around the various newsgroups and bug systems of netscape,
apache, etc. One person had a problem that sounded similar to mine, so
I asked s/he how they got over it.

They had added the following lines to /etc/rc.d/rc.local:
<<<
ifconfig lo up
route add -net 127.0.0.0 netmask 255.0.0.0 lo
>>>

I tried that, but that part of the startup didn't work:
SIOCADDRT: No such device
rc: Starting local failed

I have seen the SIOACADDRT message before, but had no idea what it was
about. It suggests that this is the problem, and that there's
something not quite right with some part of the rc init stuff.

Got any ideas? Thanks for your help.

Mike H

Comment 8 Preston Brown 1999-11-02 15:48:59 UTC
Mike:  you definitely have some sort of name lookup misconfiguration,
as installs out of the box work fine.  This isn't a bug, it is a
support issue.

Comment 9 mjhns 1999-11-21 19:21:59 UTC
Well, I think the 'problem' is in the RH installation script. At one point you
are asked whether you want to set up for a local LAN. I didn't - just wanted PPP
- and that caused (I think) this problem and one other. Because I didn't do the
LAN setup,  identd, (from netkit-base?) wasn't set up for me. That's usually OK,
but because of some work I'm doing, I'm connecting to a machine with PPP, but
because of their security, they require a static IP address, which requires
identd.

Secondly, commands to set up lo were missing from my init.rd (etc...) command
files. I was advised to add:

ifconfig lo 127.0.0.1
route add -host 127.0.0.1 lo

to one of the startup scripts, and the problem went away.

I think the solution is either to warn people at installation time that they
might need some of the LANish components even if they're not on a LAN; or to
figure out a better base for what people need even if they don't want to set up
a LAN.

This has caused a great deal of heartache for me.

Mike H


Note You need to log in before you can comment on or make changes to this bug.