Bug 582933 - knetworkmanager: "Always ask for password" does not work
knetworkmanager: "Always ask for password" does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: MoveUpstream, Patch, Triaged
: 557808 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 04:14 EDT by Michal Hlavinka
Modified: 2011-03-04 04:53 EST (History)
11 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.35.20110221.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-04 04:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 227418 None None None Never
KDE Software Compilation 244416 None None None Never

  None (edit)
Description Michal Hlavinka 2010-04-16 04:14:31 EDT
Description of problem:
I've tried to use vpnc connection with knetworkmanager, but after filling all values in configuration it does not work - it does nothing not even ask for passphrase

Version-Release number of selected component (if applicable):
knetworkmanager-0.9-0.17.20100310.fc13.x86_64
knetworkmanager-vpnc-0.9-0.17.20100310.fc13.x86_64
vpnc-script-0.5.3-7.fc13.noarch
vpnc-0.5.3-7.fc13.x86_64
NetworkManager-vpnc-0.8.0-1.git20100411.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1.configure vpnc connection, left user passphrase "always ask" (our vpn uses rsa token generated passpwords changing every minute, so it's not possible to store password)
2.click on vpn in knetworkmanager
3.
  
Actual results:
nothing, not even asked for vpn password

Expected results:
connected to vpn

Additional info:
Comment 1 Kevin Kofler 2010-04-16 10:19:28 EDT
"Always ask" doesn't work, this is known, Dennis Gilmore has been complaining about that for a while. (The VPN he uses also uses such an RSA token set up.)
Comment 2 Kevin Kofler 2010-04-16 10:21:14 EDT
CCing Dennis because he's encountered this one as well.
Comment 3 Dennis Gilmore 2010-04-16 10:28:38 EDT
I worked around it by manually setting the password. I need to update it each time i connect to the vpn
Comment 4 Michal Hlavinka 2010-04-18 08:16:27 EDT
I did not try that workaround, because waiting for rsa to show new password (so I have whole minute before it expires), change stored password for vpnc and than try to connect... it seems just crazy :)

Anyway, I don't know the answer because I did not use vpnc with knetworkmanager, but does it support the same option as gnome networkmanger:
"ipv4 : routes: [ ] Use this connection only for resources on its network" ? I can't see this setting in knetworkmanager's config options. I care about this option because I usually listen internet radio whole time and routing that CZ->USA->CZ is (at least) wasting of resources.

Is knetworkmanger going to be default for F-13 in KDE?
Comment 5 Dennis Gilmore 2010-04-18 09:33:15 EDT
There is a drop down list with basic settings, Additional addresses, and routes, The new Red Hat setup doesnt allow you to use the vpn as your default route. usually if i have 2 bars on my rsa token i have plenty of time to change the password and connect to the vpn.
Comment 6 Jeff Bastian 2010-06-03 19:04:36 EDT
I also have an RSA token and I'm experiencing this problem.  My workaround until this is resolved is to just use nm-applet like Fedora 12 and earlier, but this requires modifying the nm-applet.desktop file.

1. sudo yum erase 'knetworkmanager*'
2. sed '/NotShowIn=KDE/d' /etc/xdg/autostart/nm-applet.desktop \
      > ~/.config/autostart/nm-applet.desktop
3. Logout and login
Comment 7 Steven M. Parrish 2010-06-04 20:42:56 EDT
This is a issue which needs to be reported upstream.  Please file a report at
http://bugs.kde.org  

Please add upstream report info to this report.  We will monitor the upstream
report for a resolution.

Thanks for the report



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Rex Dieter 2010-06-05 00:21:34 EDT
Per comment #6 , here's some safer instructions so your modifications don't get lost on pkg updatse:
http://fedoraproject.org/wiki/KDE/Using_nm_applet_instead_of_knetworkmanager
Comment 9 Michal Hlavinka 2010-06-07 03:30:40 EDT
(In reply to comment #7)
> This is a issue which needs to be reported upstream.  Please file a report at
> http://bugs.kde.org  
> 
> Please add upstream report info to this report.  We will monitor the upstream
> report for a resolution.

huh? it's already here, since this bug was reported, see "external bugs"
Comment 10 Rex Dieter 2010-06-08 13:02:13 EDT
cool, thanks for the clarification.   Let's mark this triaged then.
Comment 11 Dennis Gilmore 2010-07-03 12:15:07 EDT
*** Bug 557808 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Admin XMLRPC Client 2010-09-11 19:51:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Rex Dieter 2010-11-17 11:25:57 EST
got some builds with an experimental upstream patch to help address this.  Anyone interested in testing it out?

F-14: http://koji.fedoraproject.org/koji/buildinfo?buildID=205291
F-13: http://koji.fedoraproject.org/koji/buildinfo?buildID=205292
Comment 14 Michal Hlavinka 2010-11-18 09:30:59 EST
(In reply to comment #13)
> got some builds with an experimental upstream patch to help address this. 
> Anyone interested in testing it out?
> 
> F-14: http://koji.fedoraproject.org/koji/buildinfo?buildID=205291
> F-13: http://koji.fedoraproject.org/koji/buildinfo?buildID=205292

I've tested it using vnc. I set vpnc group password (stored) and user password as always ask. It asked me for password (group password filled and input gray-disabled), so it seems it's working. But because I have my rsa token at home, I was not able to enter correct password, so I just entered 1234 as password, clicked ok and nothing has happened, no error message I'd expect. I don't know what's actual behaviour for plasma knetnowrkmanager, because I've replaced it with nm-applet a long time ago because of this bug. I'll retest with correct password and old version when I get back home to rsa token.
Comment 15 Michal Hlavinka 2010-11-18 11:29:42 EST
new and old version has the same behaviour for connected (vpn in left down says connected) and failed to connect (no error message, just connecting replaced with not connected).

Old version does not ask for password just tries to connect without second passphrase. New version asks for password. So yes, new version fixes this bug
Comment 16 Fedora Update System 2011-02-22 09:27:15 EST
kde-plasma-networkmanagement-0.9-0.35.20110221.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.35.20110221.fc13
Comment 17 Fedora Update System 2011-02-22 13:53:14 EST
kde-plasma-networkmanagement-0.9-0.35.20110221.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-plasma-networkmanagement'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.35.20110221.fc13
Comment 18 Fedora Update System 2011-03-04 04:52:44 EST
kde-plasma-networkmanagement-0.9-0.35.20110221.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.