Bug 582939 - Elapsed Time of release message all zero
Elapsed Time of release message all zero
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 582940
  Show dependency treegraph
 
Reported: 2010-04-16 04:28 EDT by Yang Ren
Modified: 2010-05-21 21:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: dhcp-4.1.1-16.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 582940 (view as bug list)
Environment:
Last Closed: 2010-05-21 21:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yang Ren 2010-04-16 04:28:19 EDT
Description of problem:
I find elapsed time for all retransmission release message are zero.

http://focus.bne.redhat.com/~ryang/ipv6ready/DHCPv6_Self_Test_P2_1_1_0_client_latest/rfc3315/59.html

Version-Release number of selected component (if applicable):
dhclient-4.1.1-13.fc12

How reproducible:
always

Steps to Reproduce:
1.start a server and a client
2.after client got address stop server
3.release client address
  
Actual results:
all release message have zero elapsed time

Expected results:
elapsed time option is not empty

Additional info:
Comment 1 Jiri Popelka 2010-04-19 07:00:50 EDT
Can you try this build ?
http://koji.fedoraproject.org/koji/buildinfo?buildID=167786
Comment 2 Yang Ren 2010-04-20 01:50:08 EDT
Verified in this build (dhcp-4.1.1-14.fc12)
Comment 3 Fedora Update System 2010-04-21 11:14:54 EDT
dhcp-4.1.1-17.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-17.fc13
Comment 4 Fedora Update System 2010-04-21 11:23:05 EDT
dhcp-4.1.1-15.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/dhcp-4.1.1-15.fc12
Comment 5 Fedora Update System 2010-04-22 18:54:02 EDT
dhcp-4.1.1-15.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-15.fc12
Comment 6 Yang Ren 2010-04-23 03:34:58 EDT
verified in dhcp-4.1.1-15.fc12
Comment 7 Fedora Update System 2010-04-30 13:10:10 EDT
dhcp-4.1.1-16.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dhcp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/dhcp-4.1.1-16.fc12
Comment 8 Yang Ren 2010-05-03 23:31:22 EDT
Hi Jiri

   The elapsed time of first confirm msg is not null in dhcp-4.1.1-16.fc12. This is a regression. dhcp-4.1.1-15.fc12 has not this problem. Pls have a check. After whole dhcp-4.1.1-16.fc12 run finished I'll re-test it to confirm the regression.

Thanks,
Comment 9 Yang Ren 2010-05-04 00:53:38 EDT
Verified. Elapsed Time of release message is ok now. I'll verified this bug and reopen bug #574677
Comment 10 Jiri Popelka 2010-05-04 01:44:46 EDT
(In reply to comment #8)
>    The elapsed time of first confirm msg is not null in dhcp-4.1.1-16.fc12.
> This is a regression. dhcp-4.1.1-15.fc12 has not this problem. Pls have a
> check. After whole dhcp-4.1.1-16.fc12 run finished I'll re-test it to confirm
> the regression.
Hi Yang,
I was not touching the code between dhcp-4.1.1-15.fc12 and dhcp-4.1.1-16.fc12.
The only change there was that I moved one script (/etc/NetworkManager/dispatcher.d/10-dhclient) from dhcp package to dhclient subpackage.
So I guess the problem is somewhere in the test.
Comment 11 Yang Ren 2010-05-04 03:03:42 EDT
(In reply to comment #10)
> (In reply to comment #8)
> >    The elapsed time of first confirm msg is not null in dhcp-4.1.1-16.fc12.
> > This is a regression. dhcp-4.1.1-15.fc12 has not this problem. Pls have a
> > check. After whole dhcp-4.1.1-16.fc12 run finished I'll re-test it to confirm
> > the regression.
> Hi Yang,
> I was not touching the code between dhcp-4.1.1-15.fc12 and dhcp-4.1.1-16.fc12.
> The only change there was that I moved one script
> (/etc/NetworkManager/dispatcher.d/10-dhclient) from dhcp package to dhclient
> subpackage.
> So I guess the problem is somewhere in the test.    

Got it. I'll test again after finish the whole test once.
Comment 12 Fedora Update System 2010-05-21 21:44:42 EDT
dhcp-4.1.1-16.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-05-21 21:49:48 EDT
dhcp-4.1.1-21.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.