Bug 582945 - smolt overwrites existing hw-uuid when run by firstboot
smolt overwrites existing hw-uuid when run by firstboot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
13
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 04:59 EDT by G.Wolfe Woodbury
Modified: 2010-05-16 00:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-16 00:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G.Wolfe Woodbury 2010-04-16 04:59:07 EDT
Description of problem:
 smolt ignores and overwrites an existing /etc/sysconfig/hw-uuid file following installation in Fedora 13.

Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. install FC13
2. restore hw-uuid file prior to reboot
3. run (firstboot)
  
Actual results:
  the existing hw-uuid is replaced in the generated report

Expected results:
  re-use the existing hw-uuid

Additional info:
  this seems to be a regression, as restoring the hw-uuid after install and before firstboot used to work (keeping the hw-uuid).  FC11 re-uses the hw-uuid, FC13 doesn't (don't know about 12 since I've skipped a cycle)
Comment 1 G.Wolfe Woodbury 2010-05-16 00:27:42 EDT
Further investigation and preusal of the sources shows that the hw-uuid file moved from /etc/sysconfig to /etc/smolt/hw-uuid.

putting the hw-uuid file in the right place solves the problem.

NOTABUG

Note You need to log in before you can comment on or make changes to this bug.