Bug 58299 - use of *chgat() function crashes ncurses-based programs
Summary: use of *chgat() function crashes ncurses-based programs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-13 16:04 UTC by Bram
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-13 16:04:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bram 2002-01-13 16:04:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221

Description of problem:
Programs that use the ncurses chgat() function will crash, since this will
trigger an infinite, recursive loop in the ncurses lib. This bug has been
confirmed by the author. Upgrading to a more recent patchlevel (or to the older
5.2-release) fixes this problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.download ftp://mud.stack.nl/pub/mp3blaster/mp3blaster-3.0.tar.gz
2.extract the source, ./configure, make
3.run src/mp3blaster

	

Actual Results:  segmentation fault

Expected Results:  A working version of the program

Additional info:

run src/mp3blaster within gdb, and do a backtrace(bt) to confirm the problem.
Not many ncurses-based programs use chgat(), that's why it probably went by
unnoticed.

Comment 1 Bernhard Rosenkraenzer 2002-01-15 11:32:11 UTC
Fixed in rawhide



Note You need to log in before you can comment on or make changes to this bug.