Bug 58305 - Only "onboot" devices are started after suspend
Summary: Only "onboot" devices are started after suspend
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apmd   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-13 22:44 UTC by Aleksey Nogin
Modified: 2007-04-18 16:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-19 23:37:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2002-01-13 22:44:50 UTC
With NET_RESTART="yes" in /etc/sysconfig/apmd only the ONBOOT=yes devices will
be started after resume. This seems somewhat wrong, although I am not sure what
a better alternative could be.

Comment 1 Matthew Saltzman 2002-01-19 22:47:03 UTC
Probably what you want is to have whatever was active at suspend time restarted.
 That seems to me to be the most reasonable alternative.

The following question seems related:  Why does my pcmcia card eth0 start when
pcmcia is started, whether ONBOOT is set or not?


Comment 2 Bernhard Rosenkraenzer 2002-01-19 23:08:20 UTC
The issue with only ONBOOT devices being started has been fixed in 3.0.2-3.
I have no idea what's causing your eth0 to not come up, works perfectly
for me.

Can you still reproduce this in 3.0.2-3?

Comment 3 Matthew Saltzman 2002-01-19 23:37:29 UTC
>I have no idea what's causing your eth0 to not come up, works perfectly for me.

No, my point is, even if ONBOOT is no, eth0 *does* start at boot time--not when
/etc/rc5.d/S10network is run, but later when S45pcmcia is run.  On a colleague's
machine with a built-in wireless card and a pcmcia network card, this causes
both interfaces to start, even when he configures the pc-card interface not to.

This has been noted elsewhere (on mailing lists, if not in bugzilla).  When
S10network runs on a laptop, the network fails to start if the interface is a
pc-card.  It starts later, when S45pcmcia runs, but it does so whether ONBOOT is
yes or no.  I recall that there was a reason for the order, but i can't recall
what it was.  But as it stands, there seems to be no way to prevent a pcmcia
interface from starting at boot.  Is this a bug?  Should it be filed anew?


Comment 4 Bernhard Rosenkraenzer 2002-01-22 11:31:44 UTC
Please file this as a new bug in kernel-pcmcia-cs [for the pcmcia init script] -
apmd can't do anything about startup order.

Closing this one because the original issue is fixed.

Comment 5 Matthew Saltzman 2002-01-22 14:54:20 UTC
Already there, as it turns out: 47529 and 10202 and 44177 (and maybe more...).

Thanks.


Note You need to log in before you can comment on or make changes to this bug.