Bug 58318 - /etc/modules.conf and APM setups don't match
Summary: /etc/modules.conf and APM setups don't match
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-14 06:39 UTC by fred-m
Modified: 2014-03-17 02:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 22:49:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fred-m 2002-01-14 06:39:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
Red Hat 7.2 puts a post-install and a pre-remove line in /etc/modules.conf to
set (and save) the mixer when sound is started (usually when first accessed) and
stopped (BTW, great idea).

(BTW, the installer didn't add these lines when I updated one of my machines
from Red Hat 7.0, only on a new install on another machine. Anyway, that's not
the bug that I'm reporting).

The installer uses "sound-slot-0" as the name of the module. But, if I set
RESTORESOUND="yes" on /etc/sysconfig/apmd, the post-install and pre-remove lines
won't be used when the sound modules are removed and re-installed, and the mixer
settings won't be saved (result: no sound after APM resume in my sound chip).
Using sound-slot-0 in SOUNDMODULES= does not work, since apmscript checks if the
module is there before removing it, so it won't find a module called
sound-slot-0 installed.

Solution: use the real module name instead of the alias sound-slot-0. In my case:
post-install i810_audio /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove i810_audio /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install, or upgrade to, Red Hat 7.2
2. Set RESTORESOUND="yes" on /etc/sysconfig/apmd, put module names on SOUNDMODULES=
3. Do an APM suspend and resume. Notice that the mixer settings were not
saved/restored.

Actual Results:  No sound (at least in my sound chip). 

Expected Results:  Sound working as it was before APM suspend.

Additional info:

Comment 1 Jeremy Katz 2002-01-14 17:21:11 UTC
kudzu writes the modules.conf, but apmd is also pulled in... reassigning to
kudzu and cc'ing bero.

Comment 2 Bill Nottingham 2005-02-04 22:49:26 UTC
Closing out bugs on older, no longer supported releases. Apologies for any lack
of response. Please attempt to confirm with more recent releases.


Note You need to log in before you can comment on or make changes to this bug.