Bug 58319 - RH7.2 does not print *certain* PostScript files
Summary: RH7.2 does not print *certain* PostScript files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: foomatic   
(Show other bugs)
Version: 7.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-14 07:09 UTC by fred-m
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-05 18:56:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PostScript file that is not getting printed (114.56 KB, application/octet-stream)
2002-01-14 07:13 UTC, fred-m
no flags Details
lpq.0 log file (error message) on system 1 (6.64 KB, text/plain)
2002-01-14 07:15 UTC, fred-m
no flags Details

Description fred-m 2002-01-14 07:09:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.2 (X11; Linux i686; U;) Gecko/20011226

Description of problem:
I have already configured printing on 3 different computers, with 3 different
printers, with RH 7.2 (see below for details). The tests on printconf-gui work,
including the A4 PostScript testpage. In fact, many PostScript files print
correctly. But I found one that doesn't. I'm attaching it below, with the lpq.0
log file. BTW, the original is a pdf file (converted to PostScript with acrobat
reader for Linux) at http://www.jnto.go.jp/english/interests/b/b3a.pdf (the
attached PostScript file has only page one of the pdf file).

It might seem to be a ghostscript problem, however ghostscript processes it
correctly. First, I can see it on the screen (with gv or ggv). And second, if I
run the command in the log file, sending the output straight to the printer
device (or sending the output to a file, then the file to the printer device) it
prints correctly! So apparently it's not a bug in ghostscript itself.

(I thought that it was the setpagedevice prepending on foomatic, but I took it
out in the perl script but I still had the same problem. BTW, the problem might
not be in foomatic).


Version-Release number of selected component (if applicable):
foomatic-1.1-0.20011018.7

How reproducible:
Always

Steps to Reproduce:
1. Try to print the attached PostScript file.
2. run the command in the log file by hand (e.g., "gs -q -dBATCH -dSAFER -dQUIET
-dNOPAUSE -sDEVICE=hpijs -dPrintMode=1 -r300x300 -sDeviceName=DJ9xx
-sOutputFile=outputfile -- test.ps"), and send outputfile straight to the
printer device (e.g., cat outputfile > /dev/usb/lp0).
 

Actual Results:  An error in the printing log file, and no output on the printer.

Expected Results:  The file being printed.

Additional info:

- System 1 has an HP DeskJet 970Cxi (hpijs driver) connected to USB
- System 2 has an Epson LP-9200SX (escpage driver) connected to the network
- System 3 has a HP LaserJet 6L (ljet4 driver) connected to the parallel port
All three show the same problem.

Comment 1 fred-m 2002-01-14 07:13:28 UTC
Created attachment 42374 [details]
PostScript file that is not getting printed

Comment 2 fred-m 2002-01-14 07:15:48 UTC
Created attachment 42375 [details]
lpq.0 log file (error message) on system 1

Comment 3 Tim Waugh 2002-01-14 08:07:52 UTC
Thanks for reporting it.  I see the same thing here.


Comment 4 Alexei Podtelezhnikov 2002-01-15 00:35:35 UTC
Shall we see ghostscript 6.52? I totally suspect that 6.51-16 is 6.52. If not, 
maybe the fix is there?


Comment 5 Tim Waugh 2002-01-15 13:13:12 UTC
See above, 'So apparently it's not a bug in ghostscript itself.'


Comment 6 Tim Waugh 2002-03-05 18:13:31 UTC
Does this still fail with the updates applied?

Comment 7 Tim Waugh 2002-03-05 18:50:29 UTC
Oh, wait, it still fails for me here (got my files mixed up).

This seems to be due to the DCA copyright stuff.  For some reason, 'gs ... - <
test.ps' fails but 'gs ... test.ps' works.  I don't know why that might be.

Comment 8 Tim Waugh 2002-03-05 18:53:57 UTC
More bizarre: 'gs ... /dev/fd/0 < test.ps' works!

Comment 9 Tim Waugh 2002-03-05 22:31:51 UTC
This can be sorted out in foomatic just by calling gs in a different way.  Fixed
package built as foomatic-1.1-0.20020130.10.


Note You need to log in before you can comment on or make changes to this bug.