Bug 583223 - network does not work after a reboot
Summary: network does not work after a reboot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-17 07:37 UTC by Yves Dorfsman
Modified: 2010-09-06 15:50 UTC (History)
6 users (show)

Fixed In Version: 2.6.34.6-47
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-04 03:59:42 UTC
Type: ---


Attachments (Terms of Use)
dmesg, /var/log/messages, /var/log/boot.log (29.02 KB, application/x-bzip2)
2010-04-17 07:37 UTC, Yves Dorfsman
no flags Details

Description Yves Dorfsman 2010-04-17 07:37:39 UTC
Created attachment 407241 [details]
dmesg, /var/log/messages, /var/log/boot.log

Description of problem:
After reboot, the cards appear as eth2 and eth3 instead of eth0 and eth1, and it is impossible to configure them. The only way to fix the problem is to unplug the computer, then on the next reboot, the interfaces show up as eth0 and eth1 again.



Version-Release number of selected component (if applicable):
kernel: 2.6.33.2-41.fc13.i686.PAE


How reproducible:
happens on every reboot.


Steps to Reproduce:
1. unplug computer
2. plug back in
3. boot up
4. network interfaces show up as eth0 and eth1 and are working
5. shutdown -h
6. switch the computer on (press button)
7. network interfaces show up as eth2 and eth3 and are NOT working


Actual results:
network interfaces appear as eth2 and eth3, and cannot be configured

Expected results:
network interfaces to always appear as eth0 and eth1, and always being able to configure them.

Additional info:
this problem never occurred with Fedora 8, 10, nor 12.

Comment 1 Yves Dorfsman 2010-04-24 20:26:50 UTC
Can we change the priority on this bug?

I makes Fedoara 13 not usable in a data centre, or remotely because it makes rebooting remotely fail 100% of the time (the network never comes back properly until power is pulled and put back in).

Comment 2 Yves Dorfsman 2010-08-01 06:45:13 UTC
After more investigation, I have found that this is a duplicate of:
https://bugs.launchpad.net/ubuntu/lucid/+source/linux/+bug/562742

I will add myself there and report the fact that the problem is still in fedora 13, and close this report.

Comment 3 Yves Dorfsman 2010-08-01 06:46:11 UTC

*** This bug has been marked as a duplicate of bug 573201 ***

Comment 4 Yves Dorfsman 2010-08-04 19:12:44 UTC
bug 573201 is specific to Fedora 12, and has been fixed. It seems that the patch applied to 2.6.32 has not been applied to 2.6.33, as the bug is still present in Fedora 13. I've been advised to re-open this bug to make sure that it gets looked at.

Comment 5 Yves Dorfsman 2010-09-04 03:59:42 UTC
This is now fixed.

I have "yum update", got package kernel-PAE-2.6.34.6-47.fc13.i686, and the problem isn't there any more.


Note You need to log in before you can comment on or make changes to this bug.