Bug 58328 - Bug in readState()
Bug in readState()
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: logrotate (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 09:28 EST by Leif Nixon
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-14 09:37:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for logrotate.c (333 bytes, patch)
2002-01-14 09:33 EST, Leif Nixon
no flags Details | Diff

  None (edit)
Description Leif Nixon 2002-01-14 09:28:52 EST
There seems to be a bug in the readState() function in logrotate.c;
an if statement checks the value of an uninitialized FILE* variable f, leading
to an "error stat()ing state file" error messsage and exit(1) if f happens
to be NULL. See attached patch.
Comment 1 Leif Nixon 2002-01-14 09:33:28 EST
Created attachment 42394 [details]
patch for logrotate.c
Comment 2 Leif Nixon 2002-01-14 09:37:07 EST
Oh, this is logrotate 3.6, BTW.
Comment 3 Elliot Lee 2002-01-29 13:59:50 EST
Fixed in CVS -> 3.6.2

Note You need to log in before you can comment on or make changes to this bug.