Bug 583289 - Wrong keyboard layout during first boot of F13 Beta
Wrong keyboard layout during first boot of F13 Beta
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2010-04-17 13:09 EDT by cschwangler
Modified: 2014-09-30 19:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-13.38-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 12:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cschwangler 2010-04-17 13:09:12 EDT
Description of problem:
After selecting UK keyboard layout in the liveCD and on the installation screen, the keyboard layout is US when the system reaches the firstboot screen after the installation. 

Version-Release number of selected component (if applicable):
I used the F13 Beta liveCD Gnome as installation media.

How reproducible:
Consistently on my system. My system is a ThinkPad T60 with UK keyboard.

Steps to Reproduce:
1. Start Gnome liveCD and select UK keyboard layout in login screen
2. Install and on keyboard selection screen select UK keyboard layout
3. In first boot screen the keyboard layout is US
  
Actual results:
Wrong keyboard layout during first boot.

Expected results:
The keyboard layout should match that selected during the installation.

Additional info:
Comment 1 wifienclair 2010-04-18 06:40:38 EDT
I have this problem too (French layout).
It may be annoying, because once installation is completed, installer asks to create a new user. But to create this new user, it uses the wrong layout.
So one can puts e.g wrong password without notice it.
Comment 2 Ales Kozumplik 2010-04-20 11:56:38 EDT
Proposing as F13Target.

In either case, the keyboard you select in your window manager has no effect on the system you later install: think about the live user as just an ordinary user on the live cd system that can have entirely different l10n preferences that the user you create during firstboot. They also have a different password etc. Also see the bug 552926.

The keyboard you select in anaconda should work though, will take a look.
Comment 3 Ales Kozumplik 2010-04-20 12:20:23 EDT
Also related is bug 568936, but that was fixed the last time I checked.
Comment 4 Ales Kozumplik 2010-04-21 04:38:11 EDT
Fixed for F13 by c971e7fe9c00e33c66118f3ef53b5ce764b02924, present in anaconda-13.38-1.

Fixed rawhide by 5b3ef0b6fd4dab6b11a3f1ebc8148c1ae8d7dc3b.
Comment 5 cschwangler 2010-04-30 04:09:35 EDT
Did a fresh install with the 2010-04-29 nightly compose and the problem is fixed.
Comment 6 cschwangler 2010-04-30 12:55:45 EDT
Retested on a second machine and it definitely works, so I am closing this.

Note You need to log in before you can comment on or make changes to this bug.