Bug 58330 - Redboot stalls loading with Zip Drive
Redboot stalls loading with Zip Drive
Status: CLOSED CURRENTRELEASE
Product: eCos
Classification: Retired
Component: RedBoot (Show other bugs)
CVS
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eCos bugs internal list
eCos bugs internal list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 11:12 EST by Drew Moseley
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-31 15:15:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Drew Moseley 2002-01-14 11:12:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13 i686)

Description of problem:
Redboot fails to boot on a PC containing a ZIP drive.  Even inserting a valid
ZIP disk does not allow it to boot.  Removing the drive from the system allows
it to boot.

In ide_init(), the Zip drive is simply detected as a disk.  
In find_partitions(), an attempt is made to read the MBR which never
returns.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install a Zip disk in a PC
2.dd if=redboot.bin of=/dev/fd0
3.Reboot the PC with the disk in the drive.
	

Actual Results:  The disk starts loading.  A number of '.' characters are
displayed on the screen.  Nothing else happens.

Expected Results:  After the '.' characters, a RedBoot> prompt should appear.

Additional info:
Comment 1 George Thomas 2002-01-14 11:25:36 EST
How is the ZIP drive connected?  I have a system here with ZIP (on SCSI)
which does have this behaviour.
Comment 2 George Thomas 2002-01-14 12:07:19 EST
Sorry, my system does _not_ show the problem.

Perhaps some diagnostics (prints, etc) in the IDE code can help since I doubt
that anyone except for Drew has hardware to test this with.
Comment 3 Drew Moseley 2002-01-14 13:17:02 EST
My Zip drive is IDE.  It is the master device on the secondary channel.
Comment 4 George Thomas 2002-01-31 15:15:16 EST
The problem is that the ZIP is an ATAPI drive and the IDE/ATAPI code does not
work with non-CDROM devices.  To fix this properly, the IDE code in RedBoot
would have to be made capable of talking to the ZIP.

For the moment, the ZIP device will simply be ignored.

Note You need to log in before you can comment on or make changes to this bug.