Bug 58333 - Install of qt-3.0.2.cvs rpm breaks font anti-aliasing
Install of qt-3.0.2.cvs rpm breaks font anti-aliasing
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 11:19 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 05:20:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-14 11:19:41 EST
Description of Problem: I have two qt's installed qt-2.3.1 and qt-3.0. Font aliasing worked fine 
until I upgraded the 3.x rpm's to the latest 3.0.2.cvs in rawhide. Now, viewing the files in 
kpackage for 2.3.1-5 shows the file listing for 3.0.2 and anti-aliasing is gone from KDE and all Qt 
apps.


Version-Release number of selected component (if applicable):


How 
Reproducible:


Steps to Reproduce:
1. rpm -ivh qt-3.0.2.cvsxxxx.rpm
2. 
3. 


Actual Results:

Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2002-01-15 06:21:55 EST
I don't think this is in any way related to your qt 3.x installation. KDE 2.x doesn't use Qt 3.x, so it doesn't even notice this installation.

If you're using some odd configuration, try setting QTDIR to /usr/lib/qt-2.3.whatever to make sure Qt 2.x (which is still used by KDE 2.x) finds all its files; this shouldn't make a difference though.

Comment 2 Need Real Name 2002-01-15 10:07:20 EST
I can infer that the 2.x libraries work from running the dynamic version of the opera browser and I 
have been installing (mostly just upgrading 3.x) and running the two qt libraries (2.x/3.x) via 
rpm for many months. My QTDIR is set to /usr/lib/qt3. Since rpm -q qt returns two entries, the way I 
have been upgrading 3.x is via rpm -e qt-3.0.x, then rpm -i qt-3.0.x (there's probably a better way). 
This paticular time, I noticed, however, that opera, KDE and other qt-based apps were no longer 
showing AA fonts. Suspicious, I checked KPackage (the way I inventory rpm's) which lists the 
files under qt-2.x as the very files for qt-3.x. I tried reinstalling qt-2.3.1-5. The package now 
shows the correct files, but still no AA. QT_XFT is set to true and qtconfig AA is selected.
Comment 3 Ngo Than 2004-09-23 05:20:42 EDT
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "CURRENTRELEASE" for now.

Note You need to log in before you can comment on or make changes to this bug.