This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 58336 - permissions error is correct, but confusing
permissions error is correct, but confusing
Status: CLOSED WONTFIX
Product: Red Hat Powertools
Classification: Retired
Component: netatalk (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 12:16 EST by Hunter Matthews
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-14 12:38:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Hunter Matthews 2002-01-14 12:16:57 EST
Description of Problem:
Our webserver is accessable through netatalk (afpd) and we use 
groups primarily to control access. Our default umask is 007, and most if not all of the dirs on 
the webserver are g+rwxs.

However, the afpd process itself did not start with a umask that 
would create the .AppleDouble dirs with write access for groups, and this led to a very hard bug 
to track down - the first person to access a particular dir would be able to read and write files 
fine, but anyone else would get a "You do not have sufficient permissions to edit this file" 
error.

However, upon looking at the webserver and reviewing a users group memberships, it 
would APPEAR that they did have sufficient access. 

Only by stracing a process with a user that 
was having the problem could I find the root cause. 



Version-Release number of selected 
component (if applicable):
1.5pre2-6

How Reproducible:
Follow the logic above and 
basically end up with an .AppleDouble dir with 
perms of rwxr-s--- and then have someone with group 
write permissions for a file try to edit the file. If they are not the owner of the .AppleDouble 
dir, they'll get the error message.

Steps to Reproduce:
1. 
2. 
3. 

Actual 
Results:


Expected Results:


Additional Information:
It may be that the error message 
you give the user can't or should not be changed - however, additional log messages would have 
been a HUGE win over having to strace the problem.

I can try to provide more details, and am 
willing to test patches if needed - I know there aren't that many sites suffering from netatalk 
anymore.	
D
Comment 1 Bernhard Rosenkraenzer 2002-01-17 16:39:04 EST
Since powertools has been discontinued and this is hardly grave enough to call for an errata update, there's nothing I can do about it, unfortunately.

Note You need to log in before you can comment on or make changes to this bug.