Bug 583386 - [abrt] crash in DomainMapper::utext
Summary: [abrt] crash in DomainMapper::utext
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:58f8e58ffa303421a7ab10e1c2f...
: 594397 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-18 09:38 UTC by kovalenko pavel
Modified: 2010-06-02 18:09 UTC (History)
3 users (show)

Fixed In Version: openoffice.org-3.2.0-12.23.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-02 18:09:48 UTC


Attachments (Terms of Use)
File: backtrace (39.95 KB, text/plain)
2010-04-18 09:38 UTC, kovalenko pavel
no flags Details
File in Russian lang - caused crash with open (370.00 KB, application/msword)
2010-04-21 14:29 UTC, kovalenko pavel
no flags Details
second File in Russian lang - caused crash (370.00 KB, application/msword)
2010-04-21 14:32 UTC, kovalenko pavel
no flags Details
Real file, that cause crash (481.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2010-04-22 12:18 UTC, kovalenko pavel
no flags Details

Description kovalenko pavel 2010-04-18 09:38:10 UTC
abrt 1.0.8 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/swriter.bin -writer
component: openoffice.org
executable: /usr/lib64/openoffice.org3/program/swriter.bin
kernel: 2.6.32.11-99.fc12.x86_64
package: openoffice.org-writer-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/swriter.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 kovalenko pavel 2010-04-18 09:38:14 UTC
Created attachment 407376 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-04-18 09:47:13 UTC
This looks like a crash in loading a specific Microsoft Office document, can you attach the document that caused it to crash ? Or send it directly to me if the document is confidential.

Comment 3 Caolan McNamara 2010-04-21 12:50:36 UTC
This is likely easy to fix if we have the .docx file that causes it. Feel free to reopen if you can provide us the document.

Comment 4 kovalenko pavel 2010-04-21 14:29:41 UTC
Created attachment 408086 [details]
File in Russian lang  - caused crash with open

File in Russian lang  - caused crash with open or sometimes just hang swriter with 100% CPU using

Comment 5 kovalenko pavel 2010-04-21 14:32:03 UTC
Created attachment 408087 [details]
second File in Russian lang  - caused crash

second File in Russian lang  - caused crash with open or sometimes just hang swriter with 100% CPU using

Comment 6 kovalenko pavel 2010-04-21 14:45:56 UTC
(In reply to comment #2)
> This looks like a crash in loading a specific Microsoft Office document, can
> you attach the document that caused it to crash ? Or send it directly to me if
> the document is confidential.    
I added 2 files (may be this files are equals - i can`t check it). When i try to open this files - crash reported or swriter hangs with 100% per one CPU loading. I send by email this files to my fried and when he try to open this files on windows (Office 2007) - all ok.

(In reply to comment #3)
> This is likely easy to fix if we have the .docx file that causes it. Feel free
> to reopen if you can provide us the document.    
It`s my first reopen bug and i cant understand how to do it, and so i select "assigned"

Comment 7 David Tardon 2010-04-22 06:52:23 UTC
Are you sure you attached the right files? Both of them opened fine on several tries and without any warning from valgrind. Moreover, they are in the old binary format (.doc), not OpenXML (.docx). If either of these files really fails to open on your system, I suspect your configuration got screwed up somehow, so it tries to import the file using OpenXML input filter. In that case, try to run

mv ~/.openoffice.org /tmp/openoffice.org

and check if the problem has gone away.

Comment 8 kovalenko pavel 2010-04-22 12:18:28 UTC
Created attachment 408304 [details]
Real file, that cause crash

I`m so sorry!!! My brains cause error :)!

This file i tried 2 times - new attached file in docx cause error.

Comment 9 Caolan McNamara 2010-04-22 13:15:38 UTC
reproducible

Comment 10 David Tardon 2010-04-22 13:43:15 UTC
dtardon->caolanm: i suppose the condition should be

if( pContext && pContext->GetFootnote().is() )

, just like the previous one. It's fixed in DEV300_m77/writerfilter07.

Comment 11 Caolan McNamara 2010-04-22 15:12:11 UTC
Yeah, but there's a slew of other problems after that one, which looks like it all needs an extensive backport from writerfilter07

Comment 12 Fedora Update System 2010-04-27 09:49:34 UTC
openoffice.org-3.2.0-12.17.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.17.fc13

Comment 13 Caolan McNamara 2010-04-27 15:58:06 UTC
Bah, unfortunately hopeless to fix for F-12. Can fix for F-13 however.

Comment 14 Fedora Update System 2010-05-15 20:33:09 UTC
openoffice.org-3.2.0-12.17.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Kevin Kofler 2010-05-16 14:59:58 UTC
> Bah, unfortunately hopeless to fix for F-12.

This just shows why we should push out application upgrades as updates. It would allow fixing bugs such as this one, and I really don't see any practical reason why OO.o 3.2 cannot be pushed to F12.

Comment 16 Caolan McNamara 2010-05-20 15:12:31 UTC
*** Bug 594397 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2010-05-22 07:21:54 UTC
openoffice.org-3.2.0-12.23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.23.fc13

Comment 18 Fedora Update System 2010-05-24 19:43:59 UTC
openoffice.org-3.2.0-12.23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/openoffice.org-3.2.0-12.23.fc13

Comment 19 Fedora Update System 2010-06-02 18:09:16 UTC
openoffice.org-3.2.0-12.23.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.