Bug 5834 - Clock is broken on Alpha Jensen platform :-(
Clock is broken on Alpha Jensen platform :-(
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: clock (Show other bugs)
6.0
alpha Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-11 10:29 EDT by mchampig
Modified: 2014-03-16 22:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-14 11:27:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mchampig 1999-10-11 10:29:01 EDT
Please add the "-J" command line arg in the
/etc/rc.d/rc.sysinit file when setting arguments for
the "clock" command. This needs to be passed on Alpha
Jensen architecture in order to set the clock
correctly. There is a line which sets "CLOCKDEFS" when
it is known we are using ARC. You have the "-A" you just
need to add "-J". To detect we are on Alpha Jensen, you
should be able to use /proc filesystem or some other
means. This is an easy fix...please apply it so Jensen
owners can have the priviledge of a real time clock. :-)
This bug has been around since RH 3.0.3!!!!
Comment 1 Bill Nottingham 1999-10-11 11:20:59 EDT
Can you send me the output of /proc/cpuinfo on a Jensen?
Comment 2 Bill Nottingham 1999-10-11 12:26:59 EDT
Eh, nevermind. Fixed in initscripts-4.52-1, assuming grepping
for Jensen in /proc/cpuinfo is enough.
Comment 3 mchampig 1999-10-12 11:18:59 EDT
Good job! Yes, grepping for "Jensen" will pick it up in the
system type field. Just one thing to note...I had a look at the
clock src.rpm and this fix is already in the binary! It does the
same check internally for the Jensen. So that means there is still
a bug lurking in the clock code. I will fix this and send a patch.
You might want to keep the "-J" hack in the init script though, since
some older RH users might not have the /proc filesystem with older
kernels. Better to be safe than sorry, but "-J" is obsolete since
we have a way at runtime to determine system types now.
Comment 4 Bill Nottingham 1999-10-13 13:10:59 EDT
Should be  fixed in clock-1.1-7, in the next Raw Hide release.
Comment 5 mchampig 1999-10-13 14:01:59 EDT
By the way, I sent you an updated patch for clock-alpha.c. It will
allow the clock to run correctly on Jensen. The 20 year offset problem
still remains but that is beyond RH to fix since it's a known bug
on very old firmware. The Jensen needs to use /dev/port to access
the clock hardware, so the fix will only affect the Jensen. This is
detected at runtime by the clock image. Thanks for applying the patch!
If you have any questions or need further testing let me know.

P.S. If you need a Jensen I may be able to have one donated to RH.
Let me know and I'll put you in touch with someone. These boxes
are flooding the market with the demise of NT on Alpha so it's in
RH best interest to support it. ;-)

Note You need to log in before you can comment on or make changes to this bug.