Bug 58343 - Laptop mouse no longer works when pluged into docking station.
Laptop mouse no longer works when pluged into docking station.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 13:52 EST by Ken McFadden
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-21 20:26:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my dmesg (9.86 KB, text/plain)
2002-04-15 08:39 EDT, Need Real Name
no flags Details
eee & iii outputs (8.75 KB, text/plain)
2002-04-15 13:02 EDT, Ken McFadden
no flags Details

  None (edit)
Description Ken McFadden 2002-01-14 13:52:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (WinNT; U)

Description of problem:
Using a Compaq laptop while pluged into docking station, mouse pointer goes to upper right corner and will only move across the top of screen.  
Mouse works fine when not in docking station.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Plug laptop into docking station.
2. boot
3. 
	

Actual Results:  Gnome login screen comes up and pointer for mouse at top of screen.

Additional info:
Comment 1 Pete Zaitcev 2002-01-17 16:22:43 EST
Please pardon me a silly question, but is this a USB mouse
(square connector) or PS/2 mouse (round connector)?

Also, it would be very helpful if requestor could
switch to other consoles with <Ctrl><Alt><F1> and back
to Gnome screen with <Alt><F7>. Then we'd have a way
to look at system status in the text mode.

Comment 2 Ken McFadden 2002-01-17 16:34:16 EST
At the moment there is neither mouse on it, but using the touch pad on the laptop......I have tried plugging a PS/2 mouse into the docking station to 
see if that would work but same problem.....I have no problems switching consoles, just let me know what you would like me to do........
Thanks,
Ken
Comment 3 Pete Zaitcev 2002-01-25 19:17:17 EST
OK, built-in is PS/2.
Comment 4 Pete Zaitcev 2002-01-25 19:24:09 EST
Found on Usenet, see quote. At least now we know it's an Armada 700.

------------------------------------------
From: tanr@mail.com (Richard Tan)
Newsgroups: comp.os.linux.portable
Subject: RedHat 7.2 on Compaq
Date: 24 Jan 2002 10:24:28 -0800
Organization: http://groups.google.com/
Lines: 4
Message-ID: <d1154739.0201241024.233a556d@posting.google.com>
NNTP-Posting-Host: 65.199.245.6
NNTP-Posting-Date: 24 Jan 2002 18:24:30 GMT

I installed RH 7.2 on my Armada 700 and everything seems to work well
except when my laptop is in the docking station, the mouse seem to
only stay on top of the screen.  It work fine un-docking.  Does anyone
know why?
Comment 5 Ken McFadden 2002-01-28 11:56:04 EST
Actually I have a Prosignia 162 which is close to the Armada 700.
Comment 6 Pete Zaitcev 2002-02-08 13:16:20 EST
So, is it possible to switch to text mode with <Alt+Ctrl+F1>
while the laptop is docked and the mouse misbehaves?

Comment 7 Need Real Name 2002-02-12 14:48:47 EST
The mouse mis-behaves in both text and X modes.  I tried a USB mouse connected 
to the docking station and it work fine!
Comment 8 Ken McFadden 2002-02-12 14:56:02 EST
I could go into text mode, but any movement of the mouse caused some very weird results.  While in text mode, shouldn't the mouse be disabled??
Comment 9 Pete Zaitcev 2002-02-12 15:06:37 EST
OK, so at least it does not produce an interrupt storm that
would lock the lappy solid.

Ken's description ("some weird results") was not very descriptive.
I suppose he may be surprised by visual effects produced by gpm.
To answer the question, yes, mouse is disabled if gpm is not running.
Otherwise, it is enabled. The X server closes its mouse when
it releases the VT on Alt-Ctrl-F1. But BIOS may re-enable it
silently from under us.

The next helpful step would be to get "dmesg" output
and /var/log/messages.

PLEASE DO NOT DROP THEM INTO THE COMMENTS BOX,
use the attachement link instead:
 https://bugzilla.redhat.com/bugzilla/createattachment.cgi?id=58343
Comment 10 Ken McFadden 2002-02-12 15:24:16 EST
Note: wierd results are as you move the mouse, Linux considers them as key strokes and you get what looks like garbage on the screen...You also 
get a white box floating around the top of the screen.
Comment 11 Pete Zaitcev 2002-04-04 14:28:52 EST
tanr, one question for you. It occured to me that the docking
station may use IRQ 12 for something. It was known to do it
on other laptops (Fujitsu's). Can you do this:
 - use USB mouse, so the box works
 - when it boots, run "dmesg > /tmp/eee" to get the dmesg output
 - "cat /proc/interrupts > /tmp/iii".
 - Attach both eee and iii to the bug as an attachement
(not as a comment)
?

Ken, if you can do it too, it would probably be helpful.

If we are lucky, it's a CD-rom in the station that sits on
a separate PCI IDE interface, or something like this.
Comment 12 Need Real Name 2002-04-15 08:39:26 EDT
Created attachment 53845 [details]
my dmesg
Comment 13 Ken McFadden 2002-04-15 13:02:30 EDT
Created attachment 53864 [details]
eee & iii outputs
Comment 14 Pete Zaitcev 2002-11-07 00:11:26 EST
HPaq has a FAQ4867:

 To disable the internal mouse, do this:
 Verify(in device manger)that the standard ps/2 driver is installed. Then go
 into the BIOS (press F10 when the cursor flashes on the right hand side
 during boot) and go to device options, and disable multiple pointing device.
 This will disable the touchpad whenever an external mouse is connected.

We do not want it actually be disabled, but I hope that wiggling some
BIOS options will help. Obviously, our problem is that either something
in the docking station delivers IRQ12 periodically, or the 8042 emulator
in BIOS goes haywire somehow.
Comment 15 Pete Zaitcev 2004-01-21 20:26:40 EST
Doesn't look fixable despite cooperative requestor.
If I had access to the hardware, perhaps then...

Note You need to log in before you can comment on or make changes to this bug.