Bug 58344 - Keyboard locks up
Keyboard locks up
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-14 13:57 EST by Sammy
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-23 09:41:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2002-01-14 13:57:30 EST
Keyboard locks up every time inittab is re-read or re-executed. If one
executes the command telinit q for example, about a second or two later
keybaord is locked.

The problem could be that mingetty and X11 are competing for the keyboard.
When this happens on gets the message "Id 1 respawning too fast......"

This is all recent rawhide stuff and there was one one person who reported
this to bugzilla earlier. I also saw few other people on the news group with
the same configuration. I have a Dell Precision 330 system but I am not
sure of the others.

Same computer worked fine with 7.2 and later rawhides but started this about
1.5 months ago.
Comment 1 Mike A. Harris 2002-01-16 11:31:13 EST
The only thing I can think of that might cause such a problem is
a misconfigured PS/2 mouse, while using a PS/2 keyboard.  This can
mess up the keyboard controller as well.  Dunno if that is relevant
or not, just a data point.

Comment 2 Sammy 2002-01-16 14:24:31 EST
Well, there was a thread on this in one of the redhat news groups. The problem
is with the 2.4.9-13 kernel....and switching to 2.4.17 kernel SOLVES the
problem. I just tested it. FYI
Comment 3 Bill Nottingham 2002-01-16 14:28:41 EST
OK, assigning to kernel.
Comment 4 Sammy 2002-01-23 09:41:14 EST
Keyboard lockups are still happening with latest rawhide. People in the news group
claim running the stock kernel 2.4.17 solved their problem. Here is EXACTLY what
happens and why it wan't happen to everybody:

If you are using an external modem via mgetty or uugetty (say port ttyS0). Every
time mgetty is respawned (call comes in) keyboard locks up. If you physically
kill mgetty or uugetty (kill -9 PidOfMgetty) the keyboard lock instantly. Since the
same thing is happening with both mgetty and getty_ps packages (compiled on
rawhide) this seems like some problem with inittab unless it is some kind of a 
lock problem. Somehow the keyboard grabbing is competing with X and locking
the keyboard.

I hope we can find a solution since this is pretty annoying.
Comment 5 Sammy 2002-01-24 14:48:58 EST
SOLVED!!! Finally I tracked it down to SysVinit-2.79-x. I upgraded sysvinit to
2.84 and all is welll now. None of the things above cause this race condition.
I am closing this and will report to packager of SysVinit as a new bug.

Note You need to log in before you can comment on or make changes to this bug.