Bug 583554 - [FEAT] mknod-mode command is needed to set mode explicitly
[FEAT] mknod-mode command is needed to set mode explicitly
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-19 01:34 EDT by Yufang Zhang
Modified: 2010-05-20 20:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-19 15:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yufang Zhang 2010-04-19 01:34:58 EDT
Description of problem:
Currently, mode is affected by umask when we create a new device file via mknod(mknod-b, mknod-c or mkfifo). Thus the mode we set in mknod is not the real mode of the device file. So we need a mknod-mode command, by which the mode we set is not affected by umask. 

Version-Release number of selected component (if applicable):
><fs> version
major: 1
minor: 0
release: 85
extra: 


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard W.M. Jones 2010-04-19 15:57:04 EDT
I've decided not to do this.  The reason is that 'mknod-mode' would
be needlessly inconsistent with 'mkdir-mode'.  The latter is affected
by umask.

However, I have updated the documentation to note the effects of
umask and how to avoid them:

http://git.annexia.org/?p=libguestfs.git;a=commitdiff;h=c2a8efc548d6f997049cbb3d63bab360b0d946b6
Comment 2 Fedora Update System 2010-04-20 15:11:55 EDT
libguestfs-1.2.3-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.el5
Comment 3 Fedora Update System 2010-04-20 18:25:24 EDT
libguestfs-1.2.3-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.fc13
Comment 4 Fedora Update System 2010-04-21 08:42:14 EDT
libguestfs-1.2.3-1.fc12.6 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/libguestfs-1.2.3-1.fc12.6
Comment 5 Fedora Update System 2010-05-20 20:31:06 EDT
libguestfs-1.2.3-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.