Bug 58367 - Trident server: Cannot switch back to X from Console
Trident server: Cannot switch back to X from Console
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 06:38 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 16:03:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xfree Config File (3.73 KB, text/plain)
2002-01-16 15:33 EST, Need Real Name
no flags Details
Xfree log file (42.34 KB, text/plain)
2002-01-16 15:35 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2002-01-15 06:38:36 EST
Description of Problem:
System runs a Trident Cyberblade i1 embedded on a MSI 6378 main board.

Component is XFree86-4.1.0-3, 7.2 System with all latest up2dates.

System cannot switch between X and console and back. After switching to console, 
system fails to produce a valid VGA signal when going back to  X (alt-f7). 

Can kill X to restore Service.

Version-Release number of selected component (if applicable): 4.1.0-3


How Reproducible: switch to console from X, try to switch back. 



Additional Information:
Using NoAccel etc does not help, it makes things worse. X totally destroys its
output with
NoAccel on this platform.
Comment 1 Mike A. Harris 2002-01-16 05:58:07 EST
What does "uname -a" report?  Also, run the following command on the machine,
without using ssh:  xdpyinfo | grep "vendor release"

Please attach both your X log, and config file using the link below.
Comment 2 Need Real Name 2002-01-16 15:33:08 EST
[root@runes main]# uname -a
Linux runes 2.4.17 #5 Tue Jan 15 01:07:32 CET 2002 i686 unknown
[root@runes main]# xdpyinfo | grep "vendor release"
vendor release number:    40100000

The error was present with kernel 2.4.7 too. I had to upgrade and 2.4.9 panics
(bug open against it already).

Xlog and config will be attached momentarily.

Btw: XFree 3 works fine on switching, but the display gets a lot of rendering
errors 
(blinking horizontal stripes on window borders) so reverting to 3 is no option.
Comment 3 Need Real Name 2002-01-16 15:33:54 EST
Created attachment 42634 [details]
Xfree Config File
Comment 4 Need Real Name 2002-01-16 15:35:11 EST
Created attachment 42635 [details]
Xfree log file
Comment 5 Alan Hourihane 2002-01-16 16:03:37 EST
This bug is already fixed in the CVS

XFree86 4.2.0 will be out soon.
Comment 6 Mike A. Harris 2002-02-09 14:23:55 EST
Fixed in 4.2.0 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.