Bug 58368 - mouse pointer does not align with its real focus point after a while
mouse pointer does not align with its real focus point after a while
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 06:42 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-16 18:31:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-15 06:42:04 EST
Description of Problem:
After a while, running a trident cyberblade i1 embedded on a MSI 6378 board, 
the X mouse pointer gets moved about 1 inch right of its real position, making
the mouse "click"
about 1 inch left of where it appears.

Version-Release number of selected component (if applicable):
XFree-4.1.0-3 (fully up2date 7.2)

How Reproducible:
use Trident driver (could not try any other). 

Additional Information:
	
Restarting X surprisingly does NOT fix this. The problem stays till reboot.

Mouse in console works fine at the same time, no disconnect of real to aparent
position in console.
Comment 1 Mike A. Harris 2002-01-16 05:39:49 EST
Does the problem go away if you use the "swcursor" option?

If not, try:  Xconfigurator --preferxf3

Do either of these suggestions help?
Comment 2 Need Real Name 2002-01-16 18:31:14 EST
I just got into the same Problem and then switched to the SWCursor option. This
seems to 
fix it for now. Will let you know when it reappears despite SWCursor. So it
seems to be indeed
a bug in HWCursor.
Comment 3 Mike A. Harris 2002-02-09 14:19:32 EST
Ok, I've updated are configuration database to default this card to "swcursor"
for now.  Please test the rawhide XFree86 4.2.0 if you get a chance, and
update the report to let us know if the hardware cursor works in rawhide,
so we can re-enable the default option.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.