Bug 58372 - Problem converting DocBook to PDF
Problem converting DocBook to PDF
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: docbook-utils (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 07:45 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 09:48:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-15 07:45:09 EST
Hello,

I am trying to produce .ps or .pdf file from the HOWTO docbook files under
/usr/share/doc/HOWTO/other-formats/docbook

I have access to two machines: A RedHat 7.1 machine and a RedHat 7.2 (that is to
say docbook-utils-0.6-13 and docbook-utils-0.6.9-2).

I live in Europe, I want documents under the A4 format...
When I produce a .ps file of NIS-HOWTO.sgml I get the following results:
On the RedHat 7.1 machine, the document is 22 pages long and is in A4 format
On the RedHat 7.2 machine, the document is 24 pages long and is in letter (US)
format. 
In both cases, I use:
 docbook2ps /usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml  -b ps

I have also problems to produce the .pdf file:
RedHat 7.2:
[root@brest root]# docbook2ps
/usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml  -b pdf
Using catalogs: /etc/sgml/sgml-docbook-3.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.9/docbook-utils.dsl#print
Working on: /usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C 7.3.3.1)
(Fatal format file error; I'm stymied)

RedHat 7.1 (it works):
[root@lorient ted]# docbook2ps NIS-HOWTO.sgml  -b pdf 
Using catalogs: /etc/sgml/sgml-docbook-3.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6/docbook-utils.dsl#print
Working on: /home/ted/NIS-HOWTO.sgml
Done.



A more general remark: I think it can be misleading to call a docbook file
xxx.sgml. I think xxx.docbook would be much more clever.
I tried at the beginning to use linuxdoc to produce from the xxx.sgml files, a
.ps or a .pdf and it did not work...
[root@brest root]# linuxdoc -B latex -p a4
/usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
Processing file /usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
 DTD check - Error: this linuxdoc-tools package supports Linuxdoc DTD only.

   If you wish to convert DocBook or other DTD files,
     then please install and use SGMLTools-Lite or Jade/OpenJade package.

 --- LinuxDoc-Tools aborting.
[root@brest root]# sgml2latex --output=ps -p a4
/usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
Processing file /usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
 DTD check - Error: this linuxdoc-tools package supports Linuxdoc DTD only.

   If you wish to convert DocBook or other DTD files,
     then please install and use SGMLTools-Lite or Jade/OpenJade package.

 --- LinuxDoc-Tools aborting.

I think it is disturbing and misleading in a way.


Thenmy final remark: Why not only one format!!!! for the HOWTOs?

Why should it be either .html, or .docbook or .sgml.
There are many converting  tools so why not furnish all the doc in only one
format, the richest one and then add a README file explaining how to produce the
other formats (.ps, .pdf, .txt, .html...) from that format.

linuxdoc allows to specify the format and the size of any "ready to print"
generated document from a .sgml. They look really good and are easy to read.
docbook2ps produces documents that are not so "good looking" and it is
impossible to specify the size of the paper (or I have not found the option...).
Isn't it possible to federate everything, to have one format (.sgml or .docbook)
and one very good looking template for everything, to obtain coherent
documentations (in term of appearance)? That would make things so much
easier.... So much professional...


In the same idea, info, html and man pages....
I like man pages, I don't like info pages.
man is easy to type and use on a console. info and .html requires too many CTR
something...
But this is MY opinion. I know some people have others. I simply go to the
simplicity, I am lazy and to type man is fast and simple....

They are many tools able to produce any of these format from a META file (.xml,
.sgml whatever) but not so many people know who they are, what they are supposed
to do and how to use them cleverly (and I am one of these people...).
Couldn't it be possible to have the 3 formats present in every RedHat packages
and placed where they are supposed to be to be easily found? That would make
everybody happy and would put some coherence (I hate to say "Jesus X, where is
the doc and in which format.!!!!")


Daniel
Comment 1 Need Real Name 2002-01-15 07:54:58 EST
I looked at the directory /usr/share/doc/HOWTO/other-formats/pdf and I found the
HOWTOs as .pef with what I call the "good look", "the beautiful appearance". How
can I reproduc it? Is there a script I could run to reproduce it? A script where
I could specify the size of my paper (A4 or US letter)

Daniel
Comment 2 Tim Waugh 2002-01-15 08:07:39 EST
Paper size:
The paper size is a stylesheet parameter: if you want to change stylesheet 
parameters you need to create a custom DSSSL stylesheet and use the -d option.

LinuxDoc:
linuxdoc-sgml is so-named in order to communicate the fact that it is only for 
LinuxDoc and not for DocBook.

File extension:
.sgml is the common convention, and I think you'll have a hard time changing 
that.  For DocBook XML, .xml is used.  Further document information than that 
is encoded in the DOCTYPE, and that is as it should be IMHO.

Many of your other comments belong in separate bugs reports against the 
component 'distribution'.

Finally, the bug:

[root@brest root]# docbook2ps
/usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml  -b pdf
Using catalogs: /etc/sgml/sgml-docbook-3.1.cat
Using stylesheet: /usr/share/sgml/docbook/utils-0.6.9/docbook-utils.dsl#print
Working on: /usr/share/doc/HOWTO/other-formats/docbook/NIS-HOWTO.sgml
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C 7.3.3.1)
(Fatal format file error; I'm stymied)

Please tell me which packages versions you have for tetex and jadetex.

(I have changed the subject line to reflect this PDF problem; if you want to 
discuss paper sizes further, please open a new bug report so that they can be 
tracked separately, otherwise we'll never know which is settled and which is 
ongoing.  Thanks.)
Comment 3 Need Real Name 2002-01-15 09:27:42 EST
Hello. Thanks for your answer.

Here are the packages version. I even tried to update docbook-utils and
docbook-style-dsssl but without success...

docbook-style-dsssl-1.74b-2.noarch.rpm 
docbook-utils-pdf-0.6.9-14.noarch.rpm
docbook-utils-0.6.9-14.noarch.rpm


[ted@brest ~]$ rpm -qa | grep tetex
tetex-latex-1.0.7-38.2
tetex-afm-1.0.7-38.2
tetex-fonts-1.0.7-38.2
tetex-dvips-1.0.7-38.2
tetex-doc-1.0.7-38.2
tetex-xdvi-1.0.7-38.2
tetex-dvilj-1.0.7-38.2
tetex-1.0.7-38.2
[ted@brest ~]$ rpm -qa | grep jadetex
jadetex-3.11-4
Comment 4 Tim Waugh 2002-01-15 09:43:43 EST
If you run (as root):

fmtutil --cnffile /usr/share/texmf/tex/jadetex/jadefmtutil.cnf --all

does that help? (This command should have been run automatically when jadetex 
was upgraded.)
Comment 5 Need Real Name 2002-01-15 09:48:43 EST
Yes. Now it works. Thanks

Daniel
Comment 6 Tim Waugh 2002-01-15 10:04:29 EST
Okay.  Not sure why it went wrong though, since jadetex has a trigger to do 
that..
Comment 7 Need Real Name 2002-01-16 05:22:28 EST
One last question. How did you produce the nice .pdf in 
/usr/share/doc/HOWTO/other-formats/pdf from the docbooks? They look very nice
and I would like to produce some in A4 format.

Daniel
Comment 8 Tim Waugh 2002-01-16 05:42:18 EST
I have no idea, and I didn't think we even shipped any package that put files 
in /usr/share/doc/HOWTO.  Why not use 'rpm -qf' to find out which package it 
belongs to and look at the spec file.
Comment 9 Need Real Name 2002-01-16 08:24:42 EST
The .spec file just untar prebuilt .pdf from linuxdoc.org...
I looked at the Linuxdoc.org website. It seems that the LDP project has its own
stylesheet:
http://www.linuxdoc.org/authors/tools/ldp.dsl.

I tried to use it with docbook but without big success. I must recognize that I
tried only 20mn and I do not have so much experience or time...
The LDP stylesheet looks very good and it would be very nice to have it
available on the RedHat boxes.

Note You need to log in before you can comment on or make changes to this bug.