Bug 58377 - 7.2 kernel trashes my IDE hard drives
7.2 kernel trashes my IDE hard drives
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 09:56 EST by Jonathan Kamens
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:22:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2002-01-15 09:56:40 EST
* SuperMicro S2DGU motherboard with two 550MHz processors.
* Promise or SIIG Ultra66 PCI IDE controller card (both of them exhibit this
problem).

The 7.2 SMP kernel rapidly trashes any UDMA hard drive plugged into one of the
controllers listed above when I start doing intensive I/O on it.  You can see
the details by searching for "Kamens" in fa.linux.kernel on groups.google.com.

The 7.2 UP kernel also sometimes trashes a hard drive, but less frequently.

The 2.4.18-pre3-ac2 kernel does not have this problem.  It is possible that some
version of Andre Hedrick's IDE patches for 2.4.x before 2.4.18-pre3-ac2 also
solved this problem -- I didn't try any patches before 2.4.18-pre3-ac2.  I did,
however, try stock 2.4.x kernels through 2.4.16, and they all exhibited this
problem.

I think a kernel update for 7.2 may be in order.
Comment 1 Alan Cox 2003-06-07 20:22:59 EDT
Which has indeed since happened

Note You need to log in before you can comment on or make changes to this bug.