Bug 583837 - Edit Drive Order tool during install is difficult to use
Edit Drive Order tool during install is difficult to use
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.5
All Linux
low Severity low
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks: 562684
  Show dependency treegraph
 
Reported: 2010-04-19 17:14 EDT by adam vinsh
Modified: 2011-07-21 02:53 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-11.1.2.226-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 02:53:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam vinsh 2010-04-19 17:14:15 EDT
Description of problem:
During an install of RHEL5.5 on a system with ~20 disks I needed to change the drive order so that GRUB was installed to the correct disk.  I got to the "Edit Drive Order" box to do this.  The problem is that every time I select a drive to move up or down in the order.. I have re-click on that drive and hit up or down again to move it.  I had 3 drives that needed to be moved to the top of the order.  This took a total of 120 clicks to accomplish due to this interface design.  I suggest the drive clicked on stays highlighted after a user clicks up or down.. so that they can continue to move the drive without the need to re-select it. 

Version-Release number of selected component (if applicable):
RHEL5.5GA

How reproducible: Every time


Steps to Reproduce:
1. Choose to Edit the Drive order during a 5.5 install.
2.
3.
  
Actual results: 120 Clicks to re-arrange 3 drives in a list of 20.


Expected results: ~30 clicks to re-arrange 3 drives in a list of 20... etc.


Additional info:
Comment 1 Hans de Goede 2010-04-26 04:49:15 EDT
Ales,

As promised some info on how to reproduce this:
1) Use a system with at least 3 drives (or just use a vm with at least 3 disks)
2) Choose custom partitioning, or check review partition layout
3) Add the bootloader screen check configure advanced bootloader options.
4) Add the advanced bootloader screen click edit bios drive order (or some such).
   Select the disk at the bottom of the drive list, and press up. Note how it no
   longer is selected, so to move this disk all the way to the top, you need
   to re-select it and then press up again.

The need to re-select it is the bug :)

Regards,

Hans
Comment 3 Ales Kozumplik 2011-02-25 09:30:50 EST
Patch awaiting review: https://www.redhat.com/archives/anaconda-devel-list/2011-February/msg00271.html
Comment 4 Ales Kozumplik 2011-03-01 13:01:26 EST
Fixed by 2607df6631114acabfd5f18799c30c549fd93042.
Comment 5 RHEL Product and Program Management 2011-03-03 04:40:00 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Alexander Todorov 2011-05-25 08:47:45 EDT
Tested with anaconda-11.1.2.235-1. 

When the user moves the selected disk up and down the disk stays selected. No need to re-select it again.
Comment 8 errata-xmlrpc 2011-07-21 02:53:02 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0984.html

Note You need to log in before you can comment on or make changes to this bug.