Bug 58395 - boot fails when building aic7xxx driver into kernel
boot fails when building aic7xxx driver into kernel
Status: CLOSED DUPLICATE of bug 126342
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
boot failure when building aic7xxx dr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 13:06 EST by Need Real Name
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 23:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-15 13:06:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
I recompiled the kerenl source from kernel-source-2.4.17-0.rpm by building
aic7xxx driver into kernel (used by root fs). I did this to avoid initrd (which
has another problem in boot when devfs is enabled). The aic7xxx driver can be
loaded during boot, and the scsi chan are dicovered, but the boot image fails to
attach the scsi disk thus cause the boot failure. The messages printed out in
console is like:
....
        (scsi0:A:0:0): Target Initiated PPR
  Vendor: COMPAQPC  Model: MAG3091MP         Rev: 1807
  Type:   Direct-Access                      ANSI SCSI revision: 02
(scsi0:A:0): 80.000MB/s transfers (40.000MHz, offset 127, 16bit)
scsi0:A:0:0: Tagged Queuing enabled.  Depth 8
md: multipath personality registered as nr 7
md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
IP: routing cache hash table of 2048 buckets, 16Kbytes
TCP: Hash tables configured (established 16384 bind 16384)
Linux IP multicast router 0.06 plus PIM-SM
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
802.1Q VLAN Support v1.6  Ben Greear <greearb@candelatech.com>
vlan Initialization complete.
request_module[block-major-8]: Root fs not mounted
VFS: Cannot open root device "805" or 08:05
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 08:05


The same config file used to compile standard kernel release 2.4.17 did succeed.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.configure the kernel by choose CONFIG_SCSI=y, CONFIG_BLK_DEV_SD=y, and
CONFIG_AIC7XXX=y.
2.recompile the kernel
3.boot
	

Actual Results:  boot fails in mounting root filesystem.

Expected Results:  boot succeed.

Additional info:
Comment 1 Need Real Name 2002-02-04 04:51:29 EST
Were you also enabling bigmem support?  Try MEM=4096 in your boot string and 
see if it starts booting OK.
Comment 2 Arjan van de Ven 2002-02-04 05:05:39 EST
* Which gcc version
* Please also try aic7xxx_old
Comment 3 Dave Jones 2004-10-29 23:43:47 EDT

*** This bug has been marked as a duplicate of 126342 ***

Note You need to log in before you can comment on or make changes to this bug.