Bug 584032 - devhelp can't display the docs
Summary: devhelp can't display the docs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cairomm
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rick L Vinyard Jr
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-20 14:59 UTC by Edward Sheldrake
Modified: 2010-07-15 21:04 UTC (History)
1 user (show)

Fixed In Version: cairomm-1.8.4-2.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-15 21:04:06 UTC


Attachments (Terms of Use)

Description Edward Sheldrake 2010-04-20 14:59:17 UTC
Description of problem:
devhelp fails to display the cairomm documentation.

Version-Release number of selected component (if applicable):
cairomm-doc-1.8.4-1.fc13

How reproducible:
Always

Steps to Reproduce:
1. Open devhelp
2. Click "cairomm Reference Manual" in the Contents tree
3.
  
Actual results:
"Error opening the requested link."

Expected results:
devhelp displays the documentation.

Additional info:
The cairomm-1.0.devhelp2 file contains http://www.cairographics.org/documentation/cairomm/reference rather than the correct path to the local files.

It would be good to move /usr/share/doc/cairomm-1.0 to /usr/share/gtk-doc/html/cairomm-1.0 , because the gtkmm docs have been similarly moved, and contain some relative html hyperlinks to the cairomm docs.

Also, there's still a copy of the html docs in the -devel package.

Comment 1 Fedora Update System 2010-07-14 15:11:55 UTC
cairomm-1.8.4-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cairomm-1.8.4-2.fc13

Comment 2 Fedora Update System 2010-07-14 23:05:59 UTC
cairomm-1.8.4-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cairomm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/cairomm-1.8.4-2.fc13

Comment 3 Fedora Update System 2010-07-15 21:04:02 UTC
cairomm-1.8.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.