Bug 584046 - RFE - try to limit dangerous queries
RFE - try to limit dangerous queries
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.5
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-20 11:36 EDT by Bill Peck
Modified: 2010-04-29 14:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 14:52:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2010-04-20 11:36:07 EDT
Description of problem:

I've seen queries on the key/value table that end up doing 20 self joins which mysql doesn't handle well.

Couple things to try here.

1 - Identify possibly problem queries, count the number of joins being built and fail if the joins are over a configured limit.

2 - Implement a timeout so that we don't wait forever on a query.
Comment 1 Raymond Mancy 2010-04-20 19:02:52 EDT
The Search could be a problem in this regard. By adding more criteria to the search they can ramp up the query to their hearts content pretty much.
Comment 2 Bill Peck 2010-04-29 14:52:32 EDT
since the query plan has been updated this doesn't seem like a problem anymore.

closing

Note You need to log in before you can comment on or make changes to this bug.