Bug 584069 - [abrt] crash in gnomint-1.0.0-2.fc12: Process /usr/bin/gnomint-cli was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in gnomint-1.0.0-2.fc12: Process /usr/bin/gnomint-cli was killed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnomint
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Huffman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d4b061552c15c54060d2d5a227f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-20 17:01 UTC by Elizabeth Nance
Modified: 2010-09-15 07:08 UTC (History)
2 users (show)

Fixed In Version: gnomint-1.2.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 05:32:06 UTC


Attachments (Terms of Use)
File: backtrace (4.02 KB, text/plain)
2010-04-20 17:01 UTC, Elizabeth Nance
no flags Details
File: comment (5.04 KB, text/plain)
2010-04-20 17:01 UTC, Elizabeth Nance
no flags Details

Description Elizabeth Nance 2010-04-20 17:01:46 UTC
abrt 1.0.8 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: gnomint-cli
Attached file: comment
component: gnomint
executable: /usr/bin/gnomint-cli
kernel: 2.6.32.11-99.fc12.i686
package: gnomint-1.0.0-2.fc12
rating: 4
reason: Process /usr/bin/gnomint-cli was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.ran gnomint-cli
2.opened existing db of certs
3.listcerts --see-revoked
4.gnoMint > crlgen 01 /home/enance/Documents/gnomint/Guard_TN_QA-allCerts/Guard_TN_QA_rev-apr20-27.crl

Comment 1 Elizabeth Nance 2010-04-20 17:01:54 UTC
Created attachment 407875 [details]
File: backtrace

Comment 2 Elizabeth Nance 2010-04-20 17:01:55 UTC
Created attachment 407876 [details]
File: comment

Comment 3 Adam Huffman 2010-06-14 22:21:31 UTC
I've reported this crash to the upstream developer.  I plan to make a test package that incorporates his latest changes and will let you know about this in this bug report.

Comment 4 David Marin Carreño 2010-08-11 07:34:48 UTC
The problem is fixed in current Git repository. Apply this patch to version 1.2.0 for fixing the problem.

--- a/src/ca-cli-callbacks.c
+++ b/src/ca-cli-callbacks.c
@@ -981,7 +981,7 @@ int ca_cli_callback_crlgen (int argc, char **argv)
                return -1;
        }
 
-       error = crl_generate (id_ca, filename);
+       error = crl_generate (id_ca, g_strdup(filename));
 
        if (! error) {
                printf (_("CRL generated successfully into file '%s'\n"), filename);

Comment 5 Fedora Update System 2010-08-27 10:35:12 UTC
gnomint-1.2.1-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc14

Comment 6 Fedora Update System 2010-08-27 10:52:21 UTC
gnomint-1.2.1-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc13

Comment 7 Fedora Update System 2010-08-27 11:17:40 UTC
gnomint-1.2.1-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc12

Comment 8 Fedora Update System 2010-08-27 17:11:29 UTC
gnomint-1.2.1-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gnomint'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/gnomint-1.2.1-1.fc14

Comment 9 Fedora Update System 2010-09-15 05:31:48 UTC
gnomint-1.2.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-09-15 05:48:05 UTC
gnomint-1.2.1-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-09-15 07:08:03 UTC
gnomint-1.2.1-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.