Bug 58409 - RFE: improve kickstart error handling for nonexistent packages
RFE: improve kickstart error handling for nonexistent packages
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 21:16 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-15 21:16:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7+) Gecko/20020111

Description of problem:
Kickstart aborts with a backtrace if a non existant package is listed in ks.cfg.
 Anaconda will die with a "uncaught exception" with a "key error".  Anaconda
should have diagnosed the error better and given a more helpful error message, a
perfect solution would be for anaconda to give you the option to skip and ignore
this package.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a ks.cfg file
2. add packages to the file, but typo at least one of them
3. Try and use the kickstart configuration
4. watcha anaconda crash and burn.


	

Actual Results:  Anaconda provides a very unhelpful traceback claiming key error
on line 64.

Expected Results:  Anaconda should have provided a more helpful error message
("Unknown package 'gf' listed in ks.cfg").  To be perfect, anaconda should have
given the user the option of ignoring that package and continuing the install.

Additional info:

The bug appears to be in kickstart.py in the procedure setPackageSelection, it
should catch the "Key Error" exception, pop up a dialog box explaining the
situation and if the user chooses to abort fail, or continue, it should remove
the package from hdlist.
Comment 1 Michael Fulbright 2002-03-26 12:30:03 EST
Deferring to future release.
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.