Bug 58414 - RTC will be corrupted.
Summary: RTC will be corrupted.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-16 05:51 UTC by Erhard Kiefner
Modified: 2014-03-17 02:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-29 21:32:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erhard Kiefner 2002-01-16 05:51:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0; Customized 
5.00.2314.1003)

Description of problem:
There is a bug in the .../init.d/halt script of Red Hat 7.1/7.2. The system 
time will be written back to the RTC during each shutdown or reboot. That's a 
bug because the system time isn't accurate. The RTC will be corrupted. You have 
to comment out the line with the hwclock command. 

Our experience: The RTC of modern PCs and servers is very exact but the system 
time already differs after a short time from the real time.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set the RTC within the BIOS setup.
2.Boot Red Hat Linux 7.1/7.2.
3.Change the system time so that's different from RTC.
4.Shutdown the system.
5.Check the RTC within the BIOS setup. It's coruupted!
	

Additional info:

Comment 1 Elliot Lee 2002-01-29 21:14:54 UTC
This is an initscripts issue.

Comment 2 Bill Nottingham 2002-01-29 21:32:48 UTC
How did you change the time?

Also, in what way is it 'corrupted'?

Comment 3 Bill Nottingham 2002-11-25 21:56:34 UTC
closing, no response


Note You need to log in before you can comment on or make changes to this bug.