This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 584158 - SELinux is preventing /usr/sbin/brctl access to a leaked /proc/mtrr file descriptor.
SELinux is preventing /usr/sbin/brctl access to a leaked /proc/mtrr file desc...
Status: CLOSED DUPLICATE of bug 571573
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:1890847bf35...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-20 16:47 EDT by David
Modified: 2010-05-17 14:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 14:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David 2010-04-20 16:47:15 EDT
Summary:

SELinux is preventing /usr/sbin/brctl access to a leaked /proc/mtrr file
descriptor.

Detailed Description:

[brctl has a permissive type (brctl_t). This access was not denied.]

SELinux denied access requested by the brctl command. It looks like this is
either a leaked descriptor or brctl output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /proc/mtrr. You should generate a bugzilla on selinux-policy, and it will
get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:brctl_t:s0-s0:c0.c1023
Target Context                system_u:object_r:mtrr_device_t:s0
Target Objects                /proc/mtrr [ file ]
Source                        brctl
Source Path                   /usr/sbin/brctl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           bridge-utils-1.2-9.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.15-4.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux vulcan 2.6.33.2-41.fc13.x86_64 #1 SMP Mon
                              Apr 12 14:09:42 UTC 2010 x86_64 x86_64
Alert Count                   124
First Seen                    Tue 20 Apr 2010 21:43:30 BST
Last Seen                     Tue 20 Apr 2010 21:44:31 BST
Local ID                      f9e92ee5-3da2-4a94-ae79-d51a97aaff52
Line Numbers                  

Raw Audit Messages            

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { write } for  pid=3072 comm="brctl" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { read } for  pid=3072 comm="brctl" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=vulcan type=AVC msg=audit(1271796271.813:37): avc:  denied  { read write } for  pid=3072 comm="brctl" path="socket:[33126]" dev=sockfs ino=33126 scontext=system_u:system_r:brctl_t:s0-s0:c0.c1023 tcontext=system_u:system_r:virtd_t:s0-s0:c0.c1023 tclass=netlink_route_socket

node=vulcan type=SYSCALL msg=audit(1271796271.813:37): arch=c000003e syscall=59 success=yes exit=0 a0=28faa90 a1=290cfa0 a2=28cf9f0 a3=8 items=0 ppid=3024 pid=3072 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="brctl" exe="/usr/sbin/brctl" subj=system_u:system_r:brctl_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,brctl,brctl_t,mtrr_device_t,file,write
audit2allow suggests:

#============= brctl_t ==============
allow brctl_t inotifyfs_t:dir read;
allow brctl_t mtrr_device_t:file write;
allow brctl_t virtd_t:netlink_route_socket { read write };
Comment 1 David 2010-04-20 16:50:34 EDT
I was trying to add a new bridged network interface via virt-manager.

To reproduce, just go to the host details in virt-manager and try and add a
bridged network.
Comment 2 Daniel Walsh 2010-04-21 11:51:27 EDT
libvirt should not be leaking.
Comment 3 Cole Robinson 2010-05-17 14:49:00 EDT
Should be fixed with latest netcf

*** This bug has been marked as a duplicate of bug 571573 ***

Note You need to log in before you can comment on or make changes to this bug.