Bug 584160 - SELinux is preventing /sbin/ifconfig access to a leaked /proc/mtrr file descriptor.
SELinux is preventing /sbin/ifconfig access to a leaked /proc/mtrr file descr...
Status: CLOSED DUPLICATE of bug 571573
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:20e414c9797...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-20 16:47 EDT by David
Modified: 2010-05-17 14:49 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-17 14:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David 2010-04-20 16:47:54 EDT
Summary:

SELinux is preventing /sbin/ifconfig access to a leaked /proc/mtrr file
descriptor.

Detailed Description:

[ip has a permissive type (ifconfig_t). This access was not denied.]

SELinux denied access requested by the ifconfig command. It looks like this is
either a leaked descriptor or ifconfig output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /proc/mtrr. You should generate a bugzilla on selinux-policy, and it will
get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:ifconfig_t:s0-s0:c0.c1023
Target Context                system_u:object_r:mtrr_device_t:s0
Target Objects                /proc/mtrr [ file ]
Source                        ip
Source Path                   /sbin/ip
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           net-tools-1.60-102.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.15-4.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.2-41.fc13.x86_64 #1 SMP Mon
                              Apr 12 14:09:42 UTC 2010 x86_64 x86_64
Alert Count                   150
First Seen                    Tue 20 Apr 2010 21:43:30 BST
Last Seen                     Tue 20 Apr 2010 21:44:31 BST
Local ID                      42a54686-16b8-46e6-a290-b36e22960b0c
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { write } for  pid=3094 comm="ifconfig" path="/proc/mtrr" dev=proc ino=4026531909 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1271796271.954:40): avc:  denied  { read } for  pid=3094 comm="ifconfig" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1271796271.954:40): arch=c000003e syscall=59 success=yes exit=0 a0=1c9d990 a1=1c9f050 a2=1c5b260 a3=8 items=0 ppid=3093 pid=3094 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="ifconfig" exe="/sbin/ifconfig" subj=system_u:system_r:ifconfig_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,ip,ifconfig_t,mtrr_device_t,file,write
audit2allow suggests:

#============= ifconfig_t ==============
allow ifconfig_t inotifyfs_t:dir read;
allow ifconfig_t mtrr_device_t:file write;
Comment 1 David 2010-04-20 16:50:09 EDT
I was trying to add a new bridged network interface via virt-manager.

To reproduce, just go to the host details in virt-manager and try and add a bridged network.
Comment 2 Daniel Walsh 2010-04-21 13:15:29 EDT
libvirt is leaking.
Comment 3 Cole Robinson 2010-05-17 14:49:12 EDT
Should be fixed with latest netcf

*** This bug has been marked as a duplicate of bug 571573 ***

Note You need to log in before you can comment on or make changes to this bug.