Bug 584229 - Kernel 2.6.33.2-57.fc13.x86_64 fails to show DVI display
Kernel 2.6.33.2-57.fc13.x86_64 fails to show DVI display
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13Blocker/F13FinalBlocker
  Show dependency treegraph
 
Reported: 2010-04-20 23:55 EDT by Andrew Bartlett
Modified: 2010-05-06 09:52 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-06 09:52:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log with new kernel (7.19 KB, text/plain)
2010-04-20 23:55 EDT, Andrew Bartlett
no flags Details
dmesg for failing kernel (121.30 KB, text/plain)
2010-04-20 23:56 EDT, Andrew Bartlett
no flags Details
Xorg.0.log with new kernel (with extra options) (8.32 KB, text/plain)
2010-04-23 08:58 EDT, Andrew Bartlett
no flags Details
dmesg for failing kernel (with extra options) (108.15 KB, text/plain)
2010-04-23 08:58 EDT, Andrew Bartlett
no flags Details
Rom as requested (64.00 KB, application/octet-stream)
2010-04-23 09:00 EDT, Andrew Bartlett
no flags Details
Xorg.0.log with working kernel (with extra options) (22.32 KB, text/plain)
2010-04-24 05:24 EDT, Andrew Bartlett
no flags Details
dmesg for working kernel (with extra options) (61.72 KB, text/plain)
2010-04-24 05:27 EDT, Andrew Bartlett
no flags Details
dmesg with 'fixed' kernel which thinks both DVI-D and VGA are connected on the DVI adaptor (89.88 KB, text/plain)
2010-04-29 08:01 EDT, Andrew Bartlett
no flags Details
xrandr from a VT when X was running thinking it had two screens (889 bytes, text/plain)
2010-04-29 08:04 EDT, Andrew Bartlett
no flags Details

  None (edit)
Description Andrew Bartlett 2010-04-20 23:55:40 EDT
Created attachment 407974 [details]
Xorg.0.log with new kernel

Description of problem:
On my DVI connector to my onboard intel chipset, this kernel (from koji) does not provide a signal to my monitor. 

It all works fine with kernel-2.6.33.1-19.fc13.x86_64

Version-Release number of selected component (if applicable):
kernel-2.6.33.2-57.fc13.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Install kernel-2.6.33.2-57.fc13.x86_64
2. Boot with DVI cable connected to DVI helper board
3.
  
Actual results:
No signal

Expected results:
Signal and desktop

Additional info:

https://bugzilla.redhat.com/show_bug.cgi?id=335501 may have additional hardware info that is relevant.
Comment 1 Andrew Bartlett 2010-04-20 23:56:25 EDT
Created attachment 407975 [details]
dmesg for failing kernel
Comment 2 Adam Jackson 2010-04-21 11:24:19 EDT
I'm curious whether this is the Intel backport or the core DRM fixes at fault.  Can you try this kernel:

http://kojipkgs.fedoraproject.org/packages/kernel/2.6.33.2/53.fc13/
Comment 3 Andrew Bartlett 2010-04-21 18:02:59 EDT
Drat, I should have updated the bug already.  That is exactly the kernel I'm using to get my display back. 

To be clear: kernel-2.6.33.2-53.fc13.x86_64 does show the display properly.
Comment 4 Adam Jackson 2010-04-22 09:37:55 EDT
Huzzah, intel backport at fault.  Looking into it, I see at least one patch that looks suspicious.

What kind of DVI add-in card are you using? How many ports does it have, how many encoder chips are on the card, etc.
Comment 5 Adam Jackson 2010-04-22 10:40:35 EDT
Also, with the broken kernel, can you boot to runlevel 3 with drm.debug=0x06, run 'X -pogo', and attach the resulting dmesg?
Comment 6 Adam Jackson 2010-04-22 16:09:39 EDT
And, as long as I'm asking for things, a copy of the video ROM would help:

# dd if=/dev/mem of=/tmp/rom bs=64k skip=12 count=1
Comment 7 Andrew Bartlett 2010-04-22 22:02:55 EDT
The card has 1 DVI port, I think it's in a PCIE slot on the motherboard. 

How do I tell what encoder chips it has etc?

It's in a Lenovo system, and the card is branded IBM.  I'll get back to you with other details later today .au time.
Comment 8 Andrew Bartlett 2010-04-23 08:58:14 EDT
Created attachment 408604 [details]
Xorg.0.log with new kernel (with extra options)
Comment 9 Andrew Bartlett 2010-04-23 08:58:59 EDT
Created attachment 408605 [details]
dmesg for failing kernel (with extra options)
Comment 10 Andrew Bartlett 2010-04-23 09:00:06 EDT
Created attachment 408606 [details]
Rom as requested

Hopefully these are all the things you need.  Feel free to ask for more info.
Comment 11 Adam Jackson 2010-04-23 14:47:59 EDT
The daughtercard is actually I-can't-believe-it's-not-PCIE, looks like the same slot but there's a handshake pin that turns it into a different kind of bus.  There should be one or two very small ASICs on the board, which should be mostly empty except for signal traces.  I suspect the silkscreening on it will say "CX-5092-A" or something similar.

The dmesg here sheds some light, but I'd like to compare it to what the working kernel did.  Can you do the same drm.debug=0x06 dmesg collection on the working kernel and attach that?
Comment 12 Andrew Bartlett 2010-04-24 05:24:26 EDT
Created attachment 408790 [details]
Xorg.0.log with working kernel (with extra options)
Comment 13 Andrew Bartlett 2010-04-24 05:27:39 EDT
Created attachment 408793 [details]
dmesg for working kernel (with extra options)

What you say about the card makes sense, from memory of when I last looked at it.  

I can pull it out to verify if you like however. 

Thanks for all your efforts on this.  As per my previous bug, it has been a long saga with this chipset and screen.
Comment 14 Adam Jackson 2010-04-26 17:54:25 EDT
Alright, I think I know what this is.  I've posted a patch that should fix this, it'll be in whatever kernel build is after 2.6.33.2-60.fc13 (hasn't been a build submitted yet, we're batching changes to go easy on the builders).

Relevant upstream thread:

http://lists.freedesktop.org/archives/intel-gfx/2010-April/006688.html
http://lists.freedesktop.org/archives/intel-gfx/2010-April/006701.html
Comment 16 Hans de Goede 2010-04-28 06:25:42 EDT
I'm seeing this too on my Intel test system. This system also has a DVI add-in card, but it is unused (the monitor is attached to the VGA output).

I've tried with both 2.6.33.2-68.fc13 and 2.6.33.3-71.fc13 to no avail.

Here is some info from my system:

00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

00:02.0 0300: 8086:2e12 (rev 03)
00:02.1 0380: 8086:2e13 (rev 03)

[drm] Initialized drm 1.1.0 20060810
i915 0000:00:02.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
i915 0000:00:02.0: setting latency timer to 64
i915 0000:00:02.0: irq 32 for MSI/MSI-X
[drm] set up 63M of stolen space
fbcon: inteldrmfb (fb0) is primary device
Console: switching to colour frame buffer device 240x75
fb0: inteldrmfb frame buffer device
registered panic notifier
[drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0

Proposing this as an F13Blocker, as with UMS support being removed from the
xorg driver, this issue really makes these systems completely unusable.
Comment 17 Hans de Goede 2010-04-28 06:27:46 EDT
BTW I can still ssh in and then the system seems to be functioning fine, so other then the display output not working things seem to work fine. Let me know what info I can provide to help debug this.
Comment 18 Fedora Update System 2010-04-28 14:37:57 EDT
kernel-2.6.33.3-72.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.3-72.fc13
Comment 19 Andrew Bartlett 2010-04-29 07:37:15 EDT
The new kernel boots the system fine, and displays to the screen at the correct resolution.

However, it thinks that the DVI connector is connected to two different monitors, a VGA and a DVI.  It then spans the desktop across both - unfortunately choosing the VGA2 as primary and as such locking me out of the menus. 

xrandr run from another virtual console shows VGA1 disconnected, and both DVI and VGA2 connected at the same resolution.  (Sorry, don't have the output to hand)

This is connected via a DVI-I KVM switch, but I have a DVI-I to DVI-D converter in the stream, so I know the VGA pins are not live. 

I guess you want the same debugging as last time?
Comment 20 Andrew Bartlett 2010-04-29 08:01:15 EDT
Created attachment 410082 [details]
dmesg with 'fixed' kernel which thinks both DVI-D and VGA are connected on the DVI adaptor
Comment 21 Andrew Bartlett 2010-04-29 08:04:08 EDT
Created attachment 410083 [details]
xrandr from a VT when X was running thinking it had two screens

This is with my KVM switch attached.  Swapping that for a direct connection while still running gave identical results.
Comment 22 Adam Jackson 2010-04-29 14:04:12 EDT
That you suddenly have a "VGA2" is kind of expected, that's the analog pins on your DVI connector.  Which is a little counterintuitive, but.

This makes sense though.  DVI only has one set of DDC pins, so we're getting the same EDID block when we look at either "connector"; we're careful to treat analog EDID blocks as "disconnected" for DVI, but we're not careful to check for the reverse.
Comment 23 Adam Williamson 2010-04-30 14:46:14 EDT
This bug was discussed at the 2010/04/30 blocker review meeting. 

It is accepted as a direct blocker as it hits the criterion "In most cases, the installed system must boot to a functional graphical environment (see Blocker_Bug_FAQ)" - https://fedoraproject.org/wiki/Fedora_13_Alpha_Release_Criteria . 

Adam Jackson believes he has a fix for this and should be able to upload a kernel for testing soon. Please test and report as soon as possible, as we will start the RC stage on Tuesday 2010/05/04.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 Adam Williamson 2010-05-03 16:41:26 EDT
Andrew, if you could test this today or early tomorrow it would be a huge help, we really need to have confirmation of the fix by then to get it in for the final F13 build. I will test for regressions with this kernel, but it'd be good to check the fix.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 26 Andrew Bartlett 2010-05-03 19:17:10 EDT
Linux naomi 2.6.33.3-78.fc13.x86_64 #1 SMP Fri Apr 30 20:25:43 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

This kernel boots and (correctly) shows only one display.

[abartlet@naomi ~]$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
DVI1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 519mm x 324mm
   1920x1200      60.0*+
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      75.0     60.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  
DVI2 disconnected (normal left inverted right x axis y axis)
VGA2 disconnected (normal left inverted right x axis y axis)


As far as I'm concerned this is good to go!

Thanks!
Comment 27 Adam Williamson 2010-05-03 21:57:07 EDT
awesome, thanks andrew.

note that the change is now incorporated in a candidate update:

https://admin.fedoraproject.org/updates/kernel-2.6.33.3-79.fc13



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 28 Adam Williamson 2010-05-03 22:09:07 EDT
kernel works with no regressions here, karma added. andrew, if you could add karma to the bodhi page (after logging in with your FAS account, see the Login link on the left) it'd really help again, tahnks!



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 29 Adam Williamson 2010-05-06 09:52:00 EDT
kernel -79 has hit stable, so let's close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.