Bug 584312 - PDF content not properly displayed
PDF content not properly displayed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 07:11 EDT by Rui Matos
Modified: 2010-09-10 23:31 EDT (History)
2 users (show)

See Also:
Fixed In Version: cairo-1.10.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-10 23:31:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 615475 None None None Never

  None (edit)
Description Rui Matos 2010-04-21 07:11:06 EDT
[ this was originally reported in gnome bug 615475 ]

On Fedora 12 with these versions:

evince-2.28.2-1.fc12.i686
poppler-0.12.4-2.fc12.i686
cairo-1.8.8-3.fc12.i686

I'm seeing a bug in the way the content of certain PDFs is displayed which
makes them unreadable.

These PDFs are bills with some personal information which I'd prefer not to
attach to a public forum like this. But I'm willing to email them personally to
a developer who can debug this issue.

I'm going to attach screenshots of the same file displayed by Preview on OS X
and Evince on Fedora 12.

</end original report>

I've also confirmed that this problem also happens on Fedora 13 Beta.

The upstream developer Carlos Garcia Campos says that the problem is fixed with poppler >= 0.13.x and cairo >= 1.9.6
Comment 1 Marek Kašík 2010-04-21 07:43:06 EDT
Hi Rui,

could you send me the PDF too? I would like to find out which patch can fix it.

Regards

Marek
Comment 2 Marek Kašík 2010-04-21 11:08:39 EDT
Hi Rui,

thank you for sending me the pdf. I've traced the problem into cairo. The problem can be fixed by the commit "Remove clip handling from generic surface layer." (included in cairo 1.9.4, SHA1 ID: bed2701e1c89095878d549cbca8f22d84f3dda3c).
I'm reassigning this to cairo.

Regards

Marek
Comment 3 Fedora Admin XMLRPC Client 2010-06-17 11:23:49 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Update System 2010-09-07 20:07:31 EDT
cairo-1.10.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/cairo-1.10.0-1.fc14
Comment 5 Fedora Update System 2010-09-07 23:17:35 EDT
cairo-1.10.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update cairo'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/cairo-1.10.0-1.fc14
Comment 6 Fedora Update System 2010-09-10 23:31:22 EDT
cairo-1.10.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.