Bug 58438 - apmd incorrectly detects battery %age
apmd incorrectly detects battery %age
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-16 11:12 EST by Need Real Name
Modified: 2007-04-18 12:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-17 06:38:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-01-16 11:12:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.7) Gecko/20020104

Description of problem:
I have an IBM iSeries 1300 1171-NM1 ThinkPad which I have Linux on.  While using
it, I noticed that my battery life was weird.  It would go from 16% to 3%
immediately.  I decided to watch it and see if it was a problem with my battery
or my apmd components.  I saw that it got to 0% and it took 30 minutes after it
hit 0% (while playing sound, so it wasn't just idle) to die.  I am using
RedHat's i686 2.4.9-13 version of the Linux kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. watch "cat /proc/apm"
2. watch the %age. It's not accurate.  .

Actual Results:  It'll hit 0% and still stay alive

Expected Results:  It should accurately describe the %age available.

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-01-17 06:32:56 EST
/proc/apm is maintained by the kernel, not by apmd.

Reassigning there, but it is much more likely that this is a BIOS bug.
Comment 2 Arjan van de Ven 2002-01-17 06:37:54 EST
The info comes DIRECTLY from the bios.... the kernel is just the messenger
Comment 3 Arjan van de Ven 2002-01-18 13:26:34 EST
Since this info doesn't come from linux but from the bios, it's "NOTOURBUG".
However bugzilla doesn't know that, the closest is "NOTABUG".
If you do not agree with this diagnoses please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.