Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 584414 - [abrt] crash in bibus-1.5.1-1.fc12: codecs.py:472:read:UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range(128)
[abrt] crash in bibus-1.5.1-1.fc12: codecs.py:472:read:UnicodeDecodeError: 'a...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: bibus (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Alex Lancaster
Fedora Extras Quality Assurance
abrt_hash:bd9eba6f
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 10:32 EDT by Joe Sapp
Modified: 2010-07-21 09:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 09:25:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.42 KB, text/plain)
2010-04-21 10:32 EDT, Joe Sapp
no flags Details

  None (edit)
Description Joe Sapp 2010-04-21 10:32:04 EDT
abrt 1.0.8 detected a crash.

architecture: x86_64
cmdline: python /usr/share/bibus/bibus.py
component: bibus
executable: /usr/share/bibus/bibus.py
kernel: 2.6.32.11-99.fc12.x86_64
package: bibus-1.5.1-1.fc12
reason: codecs.py:472:read:UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range(128)
release: Fedora release 12 (Constantine)

backtrace
-----
codecs.py:472:read:UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/bibus/BibFrame.py", line 1051, in onMenuFileImport
    self.FileImport( mod, self.__getFile(enc=mod.DEFAULT_ENCODING))
  File "/usr/share/bibus/BibFrame.py", line 1030, in FileImport
    for CurRecord in mod.importRef(f):
  File "/usr/share/bibus/Import/BibTeX.py", line 101, in __iter__
    line = self.infile.readline()
  File "/usr/lib64/python2.6/codecs.py", line 670, in readline
    return self.reader.readline(size)
  File "/usr/lib64/python2.6/codecs.py", line 525, in readline
    data = self.read(readsize, firstline=True)
  File "/usr/lib64/python2.6/codecs.py", line 472, in read
    newchars, decodedbytes = self.decode(data, self.errors)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xef in position 0: ordinal not in range(128)

Local variables in innermost frame:
exc: UnicodeDecodeError('ascii', '\xef\xbb\xbf\n@article{tran_dependence_2002,\n\ttitle = {The dependence of nadir oce', 0, 1, 'ordinal not in range(128)')
decodedbytes: 0
chars: -1
lines: []
self: <open file u'/home/sapp/blah/blah.bib', mode 'rb' at 0x2ba60b8>
newchars: u''
size: 72
data: '\xef\xbb\xbf\n@article{tran_dependence_2002,\n\ttitle = {The dependence of nadir oce'
newdata: '\xef\xbb\xbf\n@article{tran_dependence_2002,\n\ttitle = {The dependence of nadir oce'
firstline: True

How to reproduce
-----
1. Import BibTex file using ascii file encoding
Comment 1 Joe Sapp 2010-04-21 10:32:06 EDT
Created attachment 408088 [details]
File: backtrace
Comment 2 Alex Lancaster 2010-07-18 16:51:54 EDT
Can you attach the bibtex file (ideally a minimal bibtex file that reproduces the crash) so I can try to reproduce your crash on my machine?
Comment 3 Joe Sapp 2010-07-21 09:25:31 EDT
Sorry, I can't reproduce this anymore.  Additionally, I'm now running F13 so I don't know if it's still an issue in 12.

Note You need to log in before you can comment on or make changes to this bug.