Bug 584420 - Konsole stops accepting keyboard input
Summary: Konsole stops accepting keyboard input
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus   
(Show other bugs)
Version: 12
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 14:39 UTC by niklas.laxstrom+bro@gmail.com
Modified: 2010-04-30 02:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-30 02:46:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description niklas.laxstrom+bro@gmail.com 2010-04-21 14:39:55 UTC
Description of problem:
Almost always when I alt-tab from Firefox to Konsole, it does not accept any keyboard input at all. Workaround is to use mouse to switch to different tab (and back) or to another window first. It only happens form Firefox to Konsole, and only if I use alt+tab (not when I use mouse to switch from the panel.

Version-Release number of selected component (if applicable):
*Mozilla/5.0 (X11; U; Linux x86_64; fi-FI; rv:1.9.1.9) Gecko/20100330 Fedora/3.5.9-2.fc12 Firefox/3.5.9
*Konsole, Versio 2.4.2, Käytetään KDE:n kehitysalustaa 4.4.2 (KDE 4.4.2)

How reproducible:
Very.

Steps to Reproduce:
1. Start Firefox
2. Start Konsole
3. Alt+tab from Firefox to Konsole few times and try to write into Konsole

Additional info:
Problem goes away if I kill imsettings-daemon (which uses ibus), and comes back if I start it again.

Recently updated packages that may be the cause:
Apr 16 08:47:07 Updated: kdebase-workspace-libs-4.4.2-5.fc12.x86_64
Apr 16 08:47:19 Updated: kdebase-workspace-4.4.2-5.fc12.x86_64
Apr 18 09:49:15 Updated: ibus-libs-1.3.1-1.fc12.x86_64
Apr 18 09:50:25 Updated: ibus-1.3.1-1.fc12.x86_64
Apr 18 09:50:26 Updated: ibus-qt-1.3.0-1.fc12.x86_64
Apr 18 09:50:26 Updated: ibus-m17n-1.3.0-1.fc12.x86_64
Apr 18 09:50:30 Updated: ibus-gtk-1.3.1-1.fc12.x86_64
Apr 19 20:32:03 Updated: 1:qt-4.6.2-14.fc12.x86_64
Apr 19 20:32:03 Updated: 1:qt-sqlite-4.6.2-14.fc12.x86_64
Apr 19 20:32:12 Updated: 1:qt-x11-4.6.2-14.fc12.x86_64
Apr 21 08:58:30 Updated: imsettings-libs-0.108.0-2.fc12.x86_64
Apr 21 08:58:52 Updated: xorg-x11-server-common-1.7.6-3.fc12.x86_64
Apr 21 09:00:03 Updated: xorg-x11-server-Xorg-1.7.6-3.fc12.x86_64

Comment 1 Rajeesh 2010-04-23 04:34:20 UTC
Ah, add me too. I was about to file a new bug with the *same* symptoms. Though it happens with firefox and gnome-terminal too. I have observed the same issue in GNOME but with different application (MS-Outlook from Citrix) so it is not limited to KDE.
Also, downgrading ibus* packages to 1.2.0 fixes the issue.

Comment 2 Rajeesh 2010-04-29 15:54:01 UTC
Just applied ibus-1.3.2 update and the issue seems fixed.

Comment 3 Peng Huang 2010-04-30 02:46:52 UTC
Yeah. We fixed a similar bug in this version. Thanks.


Note You need to log in before you can comment on or make changes to this bug.