Bug 584450 - mkinitrd failed when convert RHEL-3.9 xen hvm image to rhev image
Summary: mkinitrd failed when convert RHEL-3.9 xen hvm image to rhev image
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-v2v
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Booth
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 15:29 UTC by Qixiang Wan
Modified: 2010-04-29 08:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-29 08:31:34 UTC


Attachments (Terms of Use)
virt-v2v.conf (3.71 KB, text/plain)
2010-04-21 15:31 UTC, Qixiang Wan
no flags Details
rhel-3.9-i386-xen-hvm.xml (1.17 KB, text/plain)
2010-04-21 15:32 UTC, Qixiang Wan
no flags Details
no_loop_error.log (173.96 KB, text/plain)
2010-04-21 15:36 UTC, Qixiang Wan
no flags Details

Description Qixiang Wan 2010-04-21 15:29:40 UTC
Description of problem:
when convert RHEL-3.9 xen hvm image to rhev image, it will failed with error "All of your loopback devices are in use" at the step of mkinitrd. cat /proc/partitions before mkinird show none loop device has been used.

--- /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm.orig	2010-04-19 10:28:15.000000000 -0400
+++ /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm	2010-04-21 10:49:54.000000000 -0400
@@ -1114,6 +1114,8 @@
             $g->modprobe("ext2");
         };
 
+        print STDERR $g->debug("sh", ["cat /proc/partitions 2>&1"]);
+
         $g->command(["/sbin/mkinitrd", @preload_args, $initrd, $version]);
     }


Version-Release number of selected component (if applicable):
virt-v2v-0.4.10-1.el5

How reproducible:
100%

Steps to Reproduce:
1. create a rhel-3.9 xen hvm guest, (on intel host in this case, both i386 and x86_64 guest are ok)

2. create a xml file as attached rhel-3.9-i386-xen-hvm.xml

3. modify /usr/share/doc/virt-v2v-0.4.10/virt-v2v.conf, see attachment

4. place the necessary packages in the directory /var/lib/virt-v2v/software which is specified in virt-v2v.conf
$ tree /var/lib/virt-v2v/software/rhel/3/
/var/lib/virt-v2v/software/rhel/3/
|-- kernel-2.4.21-50.EL.i686.rpm
|-- kernel-2.4.21-50.EL.x86_64.rpm
|-- kernel-hugemem-2.4.21-50.EL.i686.rpm
|-- kernel-smp-2.4.21-50.EL.i686.rpm
`-- kernel-smp-2.4.21-50.EL.x86_64.rpm

5. convert the images to a rhev storage
$ virt-v2v -f /usr/share/doc/virt-v2v-0.4.10/virt-v2v.conf -i libvirtxml -o rhev -osd X.X.X.X:/vol/v2v/export rhel-3.9-i386-hvm.xml

Actual results:
converting failed with error "All of your loopback devices are in use" at the step of mkinitrd, please refer to the attached log: no_loop_error.log

Expected results:
converting should pass.

Additional info:

Comment 1 Qixiang Wan 2010-04-21 15:31:37 UTC
Created attachment 408107 [details]
virt-v2v.conf

Comment 2 Qixiang Wan 2010-04-21 15:32:55 UTC
Created attachment 408111 [details]
rhel-3.9-i386-xen-hvm.xml

Comment 3 Qixiang Wan 2010-04-21 15:36:13 UTC
Created attachment 408115 [details]
no_loop_error.log

$ export LIBGUESTFS_TRACE=1
$ export LIBGUESTFS_DEBUG=1
$ virt-v2v -f /usr/share/doc/virt-v2v-0.4.10/virt-v2v.conf -i libvirtxml -o rhev -osd x.x.x.x:/export rhel-3.9-i386-hvm.xml

Comment 5 RHEL Program Management 2010-04-21 17:15:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 6 Matthew Booth 2010-04-22 12:52:47 UTC
Qixiang,

Can you confirm that this bug is supposed to be against RHEL 6? I just hit this in RHEL 5 and have a fix for that. It's caused by the loop module not being loaded. It seems loop is compiled in to the Fedora kernel, so we never hit this. I'd expect it to be compiled in on RHEL 6 too.

Matt

Comment 7 Qixiang Wan 2010-04-22 13:10:39 UTC
(In reply to comment #6)
> Qixiang,
> 
> Can you confirm that this bug is supposed to be against RHEL 6? I just hit this
> in RHEL 5 and have a fix for that. It's caused by the loop module not being
> loaded. It seems loop is compiled in to the Fedora kernel, so we never hit
> this. I'd expect it to be compiled in on RHEL 6 too.
> 
> Matt    

We hit the problem with el5 rpm package, but I didn't find virt-v2v in RHEL 5 product, so it can make you confused. I'm moving it to Virt Tools product.


Note You need to log in before you can comment on or make changes to this bug.