Bug 584500 - gnome-keyring-daemon hangs when connecting to a network with nm-applet
gnome-keyring-daemon hangs when connecting to a network with nm-applet
Status: CLOSED DUPLICATE of bug 562182
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 14:02 EDT by Matt McCutchen
Modified: 2015-03-03 17:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-01 16:32:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-keyring-daemon backtrace (1.78 KB, text/plain)
2010-04-21 14:02 EDT, Matt McCutchen
no flags Details

  None (edit)
Description Matt McCutchen 2010-04-21 14:02:19 EDT
Created attachment 408139 [details]
gnome-keyring-daemon backtrace

Description of problem:
Occasionally, when I am trying to connect to a WPA2 wireless network with nm-applet, the icon will suddenly stop animating.  I ran pstack and saw that nm-applet is waiting for a reply from gnome-keyring-daemon, which is hung waiting for a mutex.

I'm experiencing a separate issue in which attempts to connect to the network time out and nm-applet presents the "Wireless Network Authentication Required" dialog, even though the password was correct the first time.  The gnome-keyring hang seems to be triggered just before that dialog would open.  To reproduce the gnome-keyring problem on a machine not affected by the network problem, it might be necessary to enter a deliberately wrong password.

Version-Release number of selected component (if applicable):
gnome-keyring-2.28.2-2.fc12.x86_64

How reproducible:
Sometimes

Steps to Reproduce:
1. In nm-applet, select a WPA2 network for which the password has already been saved in the keyring.
  
Actual results:
nm-applet blocks waiting for a response from the hung gnome-keyring-daemon.

Expected results:
No hang, nm-applet continues to operate normally.

Additional info:
Possibly related to bug 562182.
Comment 1 Matt McCutchen 2010-05-01 16:32:47 EDT
I really think this is a duplicate of bug 562182.  I will reopen if that proves not to be the case.

*** This bug has been marked as a duplicate of bug 562182 ***

Note You need to log in before you can comment on or make changes to this bug.