Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 584503 - RFE: add xmlrpc api to disable/remove users from Beaker
Summary: RFE: add xmlrpc api to disable/remove users from Beaker
Keywords:
Status: CLOSED DUPLICATE of bug 966292
Alias: None
Product: Beaker
Classification: Retired
Component: inventory
Version: 0.5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact:
URL:
Whiteboard: CommandLineEnhancement
Depends On:
Blocks: 554806
TreeView+ depends on / blocked
 
Reported: 2010-04-21 18:10 UTC by Kevin Baker
Modified: 2018-02-06 00:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-09 07:09:53 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 966292 0 unspecified CLOSED cannot close accounts over XML-RPC 2021-02-22 00:41:40 UTC

Internal Links: 966292

Description Kevin Baker 2010-04-21 18:10:10 UTC
Need an xmlrpc call to disable/remove users from Beaker.

For now, it would be good to put a stub call in place so that the engineering-account-closure script can code the call in.

Comment 1 Nick Coghlan 2012-10-17 04:38:41 UTC
Bulk reassignment of issues as Bill has moved to another team.

Comment 2 Nick Coghlan 2013-09-09 07:09:53 UTC
Bug 966292 covers complete removal of accounts (i.e. all system reservations and loans returned, all owned systems reassigned to the admin that is removing the user).

Please file a new RFE if additional functionality is needed.

*** This bug has been marked as a duplicate of bug 966292 ***


Note You need to log in before you can comment on or make changes to this bug.