Bug 58453 - tracepath man page is garbled
Summary: tracepath man page is garbled
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: iputils (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-01-16 23:55 UTC by Chris Ricker
Modified: 2015-03-05 01:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-14 13:38:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2002-01-16 23:55:29 UTC
The tracepath man page reports that

"DESCRIPTION
       It traces path to <destination> discovering MTU along this
       path.  It uses UDP port <port> or some random port.

       tracepath6 is good replacement for traceroute6
              and  classic  example  of  application  Linux error
              queues.  tracepath is worse, because commercial  IP
              routers  do  not  return enough information in icmp
              error messages.  Probably,  it  will  change,  when
              they  will  be updated.  For now it uses Van Jacob-
              son's trick, sweaping a range of UDP ports to main-
              tain trace history.  using source address <source>.
"

I'm not quite sure what the second paragraph ("tracepath6...") is trying to say,
but I'm quite sure it's not saying it.

Comment 1 Phil Knirsch 2002-02-25 14:27:03 UTC
Errhh. Yeah... True... I am a little puzzled myself to say the least. I'm
currently updating iputils to the latest release, hopefully there is an updated
manpage included as well... That one is plainly not very helpful. :-)

Read ya, Phil

Comment 2 Phil Knirsch 2003-05-14 13:38:00 UTC
Well, there obviously wasn't. And after rereading the paragraph a couple of
times it starts to actually make some sense as the author seems to describe the
inner workings of tracepath (not really succeeding there, but still).

Therefore i decided to leave the paragraph in as it is.

Thanks,

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.