Bug 584530 - adding moni0 interface starts dhclient
Summary: adding moni0 interface starts dhclient
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 19:44 UTC by Edward Sheldrake
Modified: 2014-03-17 03:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-21 20:28:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add moni* to ignored interfaces in net.hotplug (783 bytes, patch)
2010-04-21 19:44 UTC, Edward Sheldrake
no flags Details | Diff

Description Edward Sheldrake 2010-04-21 19:44:15 UTC
Created attachment 408159 [details]
add moni* to ignored interfaces in net.hotplug

Description of problem:
On creating a virtual wireless monitor network interface (moni0), dhclient is needlessly started. wlan0 is configured using system-config-network, I'm not using NetworkManager here.

Version-Release number of selected component (if applicable):
initscripts-9.02.1-1

How reproducible:
Every time moni0 is created.

Steps to Reproduce:
1. You need some wireless hardware + driver that supports adding monitor interfaces.
2. iw phy phy0 interface add moni0 type monitor
3. check /var/log/messages
  
Actual results:
A long log message starting with something like "dhclient[30585]: dhclient(901) is already running - exiting."

NB: there's no config file for moni0, but moni0 has the same MAC address as wlan0, so the ifcfg-wlan0 file gets found.

Expected results:
dhclient isn't launched on adding moni0

Additional info:
There's a list of interface names that are ignored in net.hotplug, it just needs moni* adding to it.

Comment 1 Bill Nottingham 2010-04-21 19:58:23 UTC
It's not a great solution, simply because there could be renamed interfaces.

What's /sys/class/net/moni0/type?

Comment 2 Edward Sheldrake 2010-04-21 20:17:53 UTC
/sys/class/net/moni0/type is 803

Comment 3 Bill Nottingham 2010-04-21 20:28:08 UTC
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=955bf85bb2213cdf0cf831fab15e36a89fce2c6f

Will be in F-13, and possibly some future F-12 update.


Note You need to log in before you can comment on or make changes to this bug.