Bug 584569 - Move udisks bash completion to /etc/bash_completion.d
Summary: Move udisks bash completion to /etc/bash_completion.d
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: udisks (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-21 21:03 UTC by Ville Skyttä
Modified: 2013-02-26 19:43 UTC (History)
1 user (show)

Fixed In Version: udisks-1.0.4-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 19:43:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2010-04-21 21:03:52 UTC
All the packages I know that install bash completions install them in /etc/bash_completion.d.  I suggest changing udisks to do that as well (remember to own the /etc/bash_completion.d dir and not have a dependency on bash-completion).


Off topic, for upstream: no need to set up completion in non-interactive mode:

-[ -z "$BASH_VERSION" ] && return
+[ -z "$BASH_VERSION" -o -z "$PS1" ] && return

Comment 1 Bug Zapper 2010-07-30 11:26:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Fedora Admin XMLRPC Client 2013-02-24 10:45:14 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Dan Mashal 2013-02-25 04:21:47 UTC
Fixed in rawhide (fc19). Will try to fix for f18 and f17.

Comment 5 Ville Skyttä 2013-02-25 08:51:21 UTC
Not fixed, the file is still incorrectly in /etc/profile.d and not /etc/bash_completion.d, see initial comment. Looks like only the "off topic" change was done.

Comment 6 Dan Mashal 2013-02-25 15:31:17 UTC
Got it. I don't have commit rights for fc18 but the partial fix was done for fc18 and fc19 and it seemed to work better but I will finish the fix.

Comment 7 Ville Skyttä 2013-02-25 20:50:58 UTC
I have the needed commit rights, let me know if you'd like me to take care of this (and if, for which branches).

Comment 8 Dan Mashal 2013-02-26 03:39:40 UTC
If you have the commit rights go for it, all branches.

Comment 9 Ville Skyttä 2013-02-26 19:43:35 UTC
F17 has some other differences to F18 and I don't think this is serious enough to warrant a F17 update alone, so I committed and built F18+ only. Actually I don't think this is serious enough to warrant a F18 update alone either, so I didn't submit the bodhi update because there wasn't one for the previous build either.


Note You need to log in before you can comment on or make changes to this bug.