Bug 584574 - groupd blocks on startup when spemaphore limit exceeded.
groupd blocks on startup when spemaphore limit exceeded.
Status: CLOSED DUPLICATE of bug 561546
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 17:09 EDT by Guil Barros
Modified: 2010-05-31 09:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-31 09:23:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guil Barros 2010-04-21 17:09:09 EDT
Description of problem:
One cluster startup if there are is no more semaphore space available groupd will block and not throw an error message.

strace of groupd shows:
semget(0x11b8c82e, 3, IPC_CREAT|IPC_EXCL|0600) = -1 ENOSPC (No space left on device)
geteuid()                               = 0

ipcs -a hows semaphore count is equal to kernel.sem.

Version-Release number of selected component (if applicable):
openais-0.80.3-22.el5_3.8-x86_64

How reproducible:
- every time

Steps to Reproduce:
- Use up all semaphores
- Attempt to start cluster suite
  
Actual results:
cman startup hangs

Expected results:
Cluster startup should error out with a useful message
Comment 1 Steven Dake 2010-05-04 16:38:03 EDT
Honza,

Have a look at resolving this problem.

Also changing to 5.4 from 5.4.z since this is not a z stream regression.
Comment 2 Jan Friesse 2010-05-31 09:23:21 EDT
This bug is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=561546 so closing this bug as duplicate. You can find solution based on POSIX semaphores in mentioned bug.

*** This bug has been marked as a duplicate of bug 561546 ***

Note You need to log in before you can comment on or make changes to this bug.