Bug 584590 - Gwibber 2.30 no longer has a tray icon but instead uses libappindicator
Gwibber 2.30 no longer has a tray icon but instead uses libappindicator
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 19:32 EDT by Jef Spaleta
Modified: 2010-08-19 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: gwibber-2.31.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-27 09:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2010-04-21 19:32:19 EDT
Description of problem:

So Gwibber dropped its standard gnome notification area icon in favor of relying on libappindicate.  We don't include libappindicate so as a result our gwibber users get a suboptimal experience.

Just a heads up since I know this saw a maintainer change.  Gwibber is the first application I am aware of that relies on libappindicator entirely instead of providing an option to use a notification area applet.


Version-Release number of selected component (if applicable):
Affects current version of gwibber in F-12, F-13 and rawhide 

-jef
Comment 1 Fedora Update System 2010-04-23 15:14:37 EDT
gwibber-2.30.0.1-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.30.0.1-3.fc13
Comment 2 Fedora Update System 2010-04-23 15:15:53 EDT
gwibber-2.30.0.1-3.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.30.0.1-3.fc12
Comment 3 Fedora Update System 2010-04-25 09:53:30 EDT
gwibber-2.30.0.1-3.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Jef Spaleta 2010-04-26 17:47:46 EDT
The tray icon exists...but it doesn't work completely as expected.

When closing the main gwibber window the tray icon also disappears but leaves the gwibber-service running with no visible way to stop it.  

Closing the main qwibber window keeps the service running. 

Choosing quit from the tray icon kills the service as well as closing any existing gwibber windows.

The tray icon should remain visible as long as the background gwibber-service process is running as a means of disabling the service.  


-jef
Comment 5 Tom "spot" Callaway 2010-04-27 09:39:07 EDT
It may not be what you expect, but it is how gwibber works now.

Gwibber now has two components, a service daemon and a client. Hypothetically, there could be other clients running, like the dbus notifier bubbles (yes, gwibber treats that as a separate client now, even though it launches from the GNOME client).

If you select "Quit" from the Gwibber client, as opposed to simply closing the window, the service also quits. This is the same behavior as selecting "Quit" from the tray icon.

It would not make sense to have the tray icon persist with the service, as the tray icon is an indicator of the running GNOME client, not the gwibber service daemon. I don't want to make the gwibber service daemon launch the tray icon, because there isn't necessarily a working GNOME client, and all of the tray icon functions assume there is one.
Comment 6 Jef Spaleta 2010-04-27 12:23:36 EDT
Ah okay.. the new package does quit the service from the main window.

What threw me originally was that quitting from the previous package main window left the background service running.  If quitting from the main window is meant to kill the service then there's no problem.  

I'll watch closely to see if quitting from the main window fails to kill the service on some occasions. I could have just interpreted a failure to quit the service as intended behavior instead of a bug.

-jef
Comment 7 Fedora Update System 2010-07-26 15:25:11 EDT
gwibber-2.31.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc12
Comment 8 Fedora Update System 2010-07-26 15:30:20 EDT
gwibber-2.31.2-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc13
Comment 9 Fedora Update System 2010-08-09 16:29:45 EDT
gwibber-2.31.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12
Comment 10 Fedora Update System 2010-08-09 16:34:45 EDT
gwibber-2.31.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13
Comment 11 Fedora Update System 2010-08-19 21:54:17 EDT
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-08-19 22:08:40 EDT
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.