Bug 584592 - Inventory not UTF safe?
Inventory not UTF safe?
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: tests (Show other bugs)
0.4
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Bill Peck
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-21 19:34 EDT by Matt Brodeur
Modified: 2010-06-02 13:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 13:29:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Brodeur 2010-04-21 19:34:14 EDT
Description of problem:
I just managed to import a set of key/values which seems to upset the web UI greatly.  Loading certain systems or the Activity page results in a 500 error.

Version-Release number of selected component (if applicable):
0.4.95

As far as I can tell, this is because of a key/value which contains a non-ASCII character.  oocalc helpfully replaced several of my hyphens with en-dash, em-dash, or something else I didn't actually want.  The offending character is this one:

IBM RSA II – ibm-x3950m2-02-rsa.ovirt.rhts.eng.bos.redhat.com
          ^^^

I'm going to try to fix this in the DB to make beaker useful again, but I'd like to see a fix in the future.  Either beaker needs to handle extended characters, or the import process needs to reject them.
Comment 1 Kevin Baker 2010-04-21 19:53:36 EDT
I expect a test case to be built for this that works with UTF8 characters.
Comment 2 Raymond Mancy 2010-05-17 08:56:26 EDT
Looking at this...
Comment 3 Raymond Mancy 2010-05-23 21:58:01 EDT
If we want to deal properly with utf8, we need to do a couple more things.


1) Set up DB tables for utf8
2) Set up connector for utf8
3) Ensure the code deals in utf8 strings and not ascii
4) Display content/type as utf8

1 already is the case. 2 is easy.
3 is dealt with in some areas of the code, but it isn't systematic.
4 is already done.
Comment 4 Raymond Mancy 2010-06-01 07:34:48 EDT
http://git.fedorahosted.org/git/?p=beaker.git;a=commit;h=df9be3d206fbff65e50fd1c6e5cab2442d4263d7

This change enables System details to have UTF8 characters (not the system name though).
It also allows general viewing of UTF8 characters (although not in the URL).

Test is here

https://beaker.engineering.redhat.com/tasks/3020
Comment 5 Bill Peck 2010-06-01 12:14:19 EDT
merged. will be in next release.
Comment 6 Kevin Baker 2010-06-01 18:35:13 EDT
(In reply to comment #4)

> Test is here
> 
> https://beaker.engineering.redhat.com/tasks/3020    

Ray, thanks. is there a git link to the test source?

Be great if you could link from the beaker UI to the test source. But I think that is an RFE we have outstanding.
Comment 7 Raymond Mancy 2010-06-01 23:34:24 EDT
We keep them in CVS, try something like this:
cvs -d :ext:kbaker@cvs.devel.redhat.com:/cvs/dist co tests/distribution/beaker/import_utf8
8

Note You need to log in before you can comment on or make changes to this bug.