Bug 584598 - taskomatic/cobbler problem & cobblerd logs error "api - Exception value: 'login failed: kickstart-getData'"
taskomatic/cobbler problem & cobblerd logs error "api - Exception value: 'log...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Jan Hutař
:
Depends On:
Blocks: sat540-blockers
  Show dependency treegraph
 
Reported: 2010-04-21 20:31 EDT by Xixi
Modified: 2010-10-28 10:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-04-21 20:31:55 EDT
Description of problem:
While troubleshooting customer issue, found the following error in logs which seems to indicate communication errors between taskomatic and cobbler, especially the "kickstart-getData' login failure.  It should be using taskomatic user not this default/static string.

This could also be causing customer Satellite to sometimes result in partial deletion of profiles or general problems with taskomatic/cobbler sync'ing.

from cobblerd.log -
...
2010-04-16 14:53:00,155 - api - login attempt; user(kickstart-getData)
2010-04-16 14:53:00,304 - api - authenticate; ['kickstart-getData', False]
2010-04-16 14:53:00,304 - api - login failed; user(kickstart-getData)
2010-04-16 14:53:00,304 - api - Exception occured: cobbler.cexceptions.CX
2010-04-16 14:53:00,304 - api - Exception value: 'login failed: kickstart-getData'
2010-04-16 14:53:00,305 - api - Exception Info:
 File "/usr/lib/python2.4/site-packages/cobbler/remote.py", line 1567, in _dispatch
   return method_handle(*params)
  File "/usr/lib/python2.4/site-packages/cobbler/remote.py", line 1033, in login
   raise CX(_("login failed: %s") % login_user)
...

rhn_taskomatic_daemon.log -
...
INFO   | jvm 1    | 2010/04/16 16:05:00 | 2010-04-16 16:05:00,023 [DefaultQuartzScheduler_Worker-3] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask - RuntimeExceptioneError trying to sync to cobbler: XmlRpcException calling cobbler.
INFO   | jvm 1    | 2010/04/16 16:05:00 | java.lang.RuntimeException: XmlRpcException calling cobbler.
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:72)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at com.redhat.rhn.taskomatic.task.CobblerSyncTask.execute(CobblerSyncTask.java:76)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at com.redhat.rhn.taskomatic.task.SingleThreadedTestableTask.execute(SingleThreadedTestableTask.java:54)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at org.quartz.core.JobRunShell.run(JobRunShell.java:203)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:520)
INFO   | jvm 1    | 2010/04/16 16:05:00 | Caused by:
INFO   | jvm 1    | 2010/04/16 16:05:00 | redstone.xmlrpc.XmlRpcException: The response could not be parsed.
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:434)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at redstone.xmlrpc.XmlRpcClient.endCall(XmlRpcClient.java:376)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at redstone.xmlrpc.XmlRpcClient.invoke(XmlRpcClient.java:165)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at com.redhat.rhn.manager.kickstart.cobbler.CobblerXMLRPCHelper.invokeMethod(CobblerXMLRPCHelper.java:69)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       ... 4 more
INFO   | jvm 1    | 2010/04/16 16:05:00 | Caused by:
INFO   | jvm 1    | 2010/04/16 16:05:00 | java.io.IOException: Server returned HTTP response code: 503 for URL: http://suwsmnsat01.hosting.ops:80/cobbler_api
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1308)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       at redstone.xmlrpc.XmlRpcClient.handleResponse(XmlRpcClient.java:420)
INFO   | jvm 1    | 2010/04/16 16:05:00 |       ... 7 more
INFO   | jvm 1    | 2010/04/16 16:05:00 | 2010-04-16 16:05:00,023 [DefaultQuartzScheduler_Worker-3] ERROR com.redhat.rhn.taskomatic.task.CobblerSyncTask - Not re-throwing any more errors.
...

catalina.out -
...
2010-04-16 00:01:00,187 [TP-Processor8] INFO  com.redhat.rhn.frontend.xmlrpc.LoggingInvocationProcessor - REQUESTED FROM: *callerIp* CALL: auth.checkAuthToken(kickstart-getData, 5fea6323c3085be265cb470160069791xe5083d6b8b92ae9f68bdd7c73fcd5c7b) CALLER: (satadmin) TIME: 0.0 seconds
2010-04-16 00:01:00,261 [TP-Processor8] ERROR com.redhat.rhn.frontend.xmlrpc.BaseHandler - Error calling method:
java.lang.reflect.InvocationTargetException
...
Caused by:
com.redhat.rhn.frontend.xmlrpc.UserLoginException: Either the password or username is incorrect.
       at com.redhat.rhn.frontend.xmlrpc.auth.AuthHandler.login(AuthHandler.java:104)
       at com.redhat.rhn.frontend.xmlrpc.auth.AuthHandler.login(AuthHandler.java:75)
       ... 40 more
...

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

How reproducible:
Have not seen it on all Satellites, but it's consistently happening for this customer's, and Justin said he ran into this too.

Steps to Reproduce:
1. Have 5.3.0 Satellite with cobbler running.
2. Create/modify some kickstart profiles and look at logs.

Actual results:
See above.

Expected results:
No errors.

Additional info:
Per Justin - this is already fixed in spacewalk with commit 6e4faf231fd4ca1d0159e5988a00cb2d60338e2f (https://fedorahosted.org/spacewalk/changeset?new=java%2Fcode%406e4faf231fd4ca1d0159e5988a00cb2d60338e2f&old=java%2Fcode%40607afc48fb7656bf8fe82e4139d8a7d25182fdbd) 

Open BZ to port to Satellite.
Comment 2 Justin Sherrill 2010-04-22 10:01:30 EDT
Since this is already fixed in master, moving to modified.
Comment 5 Michael Mráka 2010-10-22 08:12:04 EDT
Verified in stage.

No errors in /var/log/cobbler/cobbler.log /var/log/rhn/rhn_taskomatic_daemon.log  /var/log/tomcat5/catalina.out during kickstart modification.
Comment 6 Clifford Perry 2010-10-28 10:52:00 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.