Bug 584600 - Unable to provision/kickstart & cobblerd fails to start with error message "invalid profile name" if a system config references non-existent ks profile
Unable to provision/kickstart & cobblerd fails to start with error message "i...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
high Severity high
: ---
: ---
Assigned To: Justin Sherrill
Garik Khachikyan
:
Depends On:
Blocks: sat540-blockers
  Show dependency treegraph
 
Reported: 2010-04-21 20:51 EDT by Xixi
Modified: 2015-01-04 16:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-28 10:51:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-04-21 20:51:13 EDT
Description of problem:
Customer deletes a few ks profiles and then finds himself no longer able to use provisioning functionality b/c cobblerd fails to start with error message "invalid profile name (<name-of-profile-he-just-deleted>)". cobbler commands such as "cobbler report" and "cobbler profile list" returns same error. The profile was deleted successfully, and is not in /var/lib/cobbler/config/profiles.d/ nor is it in rhnKsData in database.  It turns out that one of the system configs in /var/lib/cobbler/config/systems.d/ still has a reference to the deleted profile, and fixing that manually brought back cobbler/kickstart functionality.  We're not sure how that happened since cobbler system list does not show this system, so that itself is problematic, however cobbler should handle this better:

There're 3 parts to this bug -
1. possible incomplete deletion of cobbler profile such that not all system configs referring to profile are removed, and/or incomplete deletion of system configs (have not been able to reproduce this, so not certain, unlike parts 2 & 3 below);
2. need better error message - instead of just saying "invalid profile name", it should tell the user where the error is occuring, for example "unable to find profile xyz used by system abc".
3. need better error-handling - just b/c one config file has issues should not cause the entire cobbler/provisioning functionality to crash down, it needs to report the error and allow the rest of the kickstart functinality to remain working. 

Version-Release number of selected component (if applicable):
Red Hat Network (RHN) Satellite 5.3.0

System architecture(s):
arch=x86_64
release=5
flavor=server
base=rhel-x86_64-server-5

How reproducible:
Always.

Steps to Reproduce:
1. 5.3 Satellite with >=2 ks profiles with some system configs.
2. delete one of the profiles, however leave one of the configs still referring to the deleted profile in "profile"
3. try to provision systems, restart cobblerd, and/or do "cobbler profile list" etc..

Actual results:
See above.

Expected results:
See parts 2 & 3 above.

Additional info:
Comment 2 Justin Sherrill 2010-07-26 16:53:47 EDT
This should be fixed in the newest cobbler, which i Hope we will rebase against.  Will be somewhat hard to fix if we don't.
Comment 3 Justin Sherrill 2010-08-25 14:52:46 EDT
Latest iso should have newest cobbler. Moving to ON_QA
Comment 5 Garik Khachikyan 2010-10-11 06:50:11 EDT
# VERIFIED

the issue described in comment#0 is not reproducible in sat540:

1. make ks profile
2. prepare >=2 system records wit this ks profile (assure they are in: /var/lib/cobbler/config/systems.d)
3. remove the ks profile from satellite UI
---
result:
all system records associated with this ks profile are cleaned.
no problem with cobbler profile list or any other cobbler commands at all.

considering the issue as verified.
Comment 8 Clifford Perry 2010-10-28 10:46:43 EDT
The 5.4.0 RHN Satellite and RHN Proxy release has occurred. This issue has been resolved with this release. 


RHEA-2010:0801 - RHN Satellite Server 5.4.0 Upgrade
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10332

RHEA-2010:0803 - RHN Tools enhancement update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10333

RHEA-2010:0802 - RHN Proxy Server 5.4.0 bug fix update
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10334

RHEA-2010:0800 - RHN Satellite Server 5.4.0
https://rhn.redhat.com/rhn/errata/details/Details.do?eid=10335

Docs are available:

http://docs.redhat.com/docs/en-US/Red_Hat_Network_Satellite/index.html 

Regards,
Clifford

Note You need to log in before you can comment on or make changes to this bug.