This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 584603 - goddard KDM and KSplash themes broken
goddard KDM and KSplash themes broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: goddard-kde-theme (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13blocker-KDE
  Show dependency treegraph
 
Reported: 2010-04-21 21:23 EDT by Rex Dieter
Modified: 2010-05-03 10:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 10:29:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2010-04-21 21:23:32 EDT
goddard-backgrounds-13.0.0-1.fc13 switched from png's to jpg's, and broke our kdm theming.
Comment 1 Rex Dieter 2010-04-21 21:24:58 EDT
tested with:
$ rpm -q goddard-backgrounds-single goddard-kde-theme
goddard-backgrounds-single-13.0.0-1.fc13.noarch
goddard-kde-theme-12.91.1-1.fc13.noarch
Comment 2 Kevin Kofler 2010-04-21 21:36:31 EDT
This also breaks KSplash, and at least KSplash definitely does not support JPG, only PNG. :-(
Comment 3 Kevin Kofler 2010-04-22 00:49:56 EDT
I made an experimental Qt-based fork of KSplashX, which should support any image type Qt supports:
http://repo.calcforge.org/f13/ksplashq.tar.bz2
But so far I only tested it with "./ksplashq SolarComet --test".
It only supports fullscreen themes, the GEOMETRY and GEOMETRY_REL commands are silently ignored. All other KSplashX commands should work.
Comment 4 Kevin Kofler 2010-04-22 00:50:30 EDT
(Oh, and I didn't test it on Xinerama, only on a single 1280×1024 screen.)
Comment 5 Jaroslav Reznik 2010-04-22 04:37:38 EDT
Oh, no! I have already contacted Martin Sourada on design list. I didn't expect this changes so late :(
Comment 6 Rex Dieter 2010-04-22 08:35:19 EDT
As I mentioned on irc last night, since ksplash only really needs a single png, we could embed a png copy (converted from the jpg original) here too.

Long term, Kevin's solution about enhancing ksplash is indeed the way to go.  You know the drill, submit it upstream for feedback.
Comment 7 Fedora Update System 2010-04-22 12:53:11 EDT
goddard-kde-theme-13.0.0-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/goddard-kde-theme-13.0.0-1.fc13
Comment 8 Fedora Update System 2010-04-23 02:02:21 EDT
goddard-kde-theme-13.0.0-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update goddard-kde-theme'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/goddard-kde-theme-13.0.0-1.fc13
Comment 9 Fedora Update System 2010-04-25 09:45:43 EDT
goddard-kde-theme-13.0.1-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update goddard-kde-theme'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/goddard-kde-theme-13.0.1-1.fc13
Comment 10 Rex Dieter 2010-05-03 10:29:19 EDT
bodhi - 2010-04-29 07:09:23
 
 This update has been pushed to stable

Note You need to log in before you can comment on or make changes to this bug.