Bug 584632 - [abrt] crash in compiz-0.8.6-1.fc13: Process /usr/bin/compiz was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in compiz-0.8.6-1.fc13: Process /usr/bin/compiz was killed by si...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:98543041045e987554db2ff5e16...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-22 05:17 UTC by GoinEasy9
Modified: 2010-05-01 03:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-01 03:58:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (40.30 KB, text/plain)
2010-04-22 05:17 UTC, GoinEasy9
no flags Details

Description GoinEasy9 2010-04-22 05:17:16 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: compiz --ignore-desktop-hints ccp --replace
component: compiz
executable: /usr/bin/compiz
global_uuid: 98543041045e987554db2ff5e1648f0c1fa89a6e
kernel: 2.6.33.2-57.fc13.i686.PAE
package: compiz-0.8.6-1.fc13
rating: 4
reason: Process /usr/bin/compiz was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

comment
-----
Bug Notification Icon came up immediately after switching Desktop Effects.  Compiz effects were working previously.  Updates came in Tuesday 4/20 and Wednesday 4/21 since I last tested effects.  I also installed Gnome-Do to test out effects.  Tried a second time after switching back to Standard effects and reproduced bug before filing.
System Info:
System:    Host Fedora13dw32 Kernel 2.6.33.2-57.fc13.i686.PAE i686 (32 bit) Distro Fedora release 13 (Goddard)
CPU:       Quad core AMD Phenom II X4 955 (SMP) cache 2048 KB flags (lm nx sse sse2 sse3 sse4a svm) bmips 25598.7 
           Clock Speeds: (1) 800.00 MHz (2) 800.00 MHz (3) 800.00 MHz (4) 800.00 MHz
Graphics:  Card nVidia G92 [GeForce 9800 GT] Fedora 1.8 Res: 1920x1080@60.0hz, 1920x1080@60.0hz 
           GLX Renderer Gallium 0.4 on NV92 GLX Version 2.1 Mesa 7.8.1 Direct Rendering Yes

How to reproduce
-----
1. Switched from Standard to Compiz in desktop effects
2.
3.

Comment 1 GoinEasy9 2010-04-22 05:17:18 UTC
Created attachment 408235 [details]
File: backtrace

Comment 2 Jeff Raber 2010-04-28 00:02:50 UTC
Thanks for the bug report.  Please attach your X server config file (/etc/X11/xorg.conf, if available), output of the dmesg command, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

Thanks in advance.

Assigning to mesa as this appears to be a problem with the experimental gallium driver.  

Mesa team, feel free to move it back if you think I am wrong.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 GoinEasy9 2010-04-29 03:11:05 UTC
Thanks for your response.  I don't know if attaching those files will help you at this point because my desktops effects have been working again since the update on Monday, April 26th seemed to solve the problem.

Files that were updated that day were:
Apr 26 18:48:43 Updated: xorg-x11-server-common-1.8.0-8.fc13.i686
Apr 26 18:48:44 Updated: xorg-x11-server-Xorg-1.8.0-8.fc13.i686
Apr 26 18:48:46 Updated: coolkey-1.1.0-14.fc13.i686

I just checked a forum comment I made, and, it was indeed after this update that I got desktop effects back.  The abrt error seemed to have disappeared after the update of mesa-dri-drivers and mesa-dri-drivers experimental on Friday, April 23rd, although desktop effects were still broken.

Due my work schedule Tuesday and Wednesday, I wasn't able to check to see what might have fixed the problem, but after seeing your post I looked back so I could give you a timeline.  

I have just updated tonight, and checked my desktop effects multiple times, going back and forth between 2D and Compiz and at the moment have no problems or errors popping up.

If there is some other way I can help, please don't hesitate to ask.

Comment 4 Jeff Raber 2010-05-01 03:58:44 UTC
GoinEasy9, Thanks for the information.  It looks like the latest mesa release combined with the latest xorg-x11-server release fixed quite a few issues.  Hopefully yours was one of them and you will not see this crash again.

Closing the BZ.  Please reopen it if the error recurs.


Note You need to log in before you can comment on or make changes to this bug.